Announcement

Collapse

Mirth Connect 4.1.0 Released!

Mirth Connect 4.1.0 is now available as an appliance update and on our GitHub page. Mirth Connect 4.1.0 includes new features such as new event log messages, additional fields to the Welcome to Mirth Connect screen, new information included in alerts as well as many smaller changes, updates, and improvements. This release also contains several improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Mirth dropping repeating ~ characters in OBX:5

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth dropping repeating ~ characters in OBX:5

    Has anyone seen this issue before? We have Radiology results comming across on an interface, and in the Observation Field of the OBX system the DR PACS sends LineFeeds as ~ characters. In the case of more than one line feed ~~ or ~~~ Mirth strips off the following ~. So if you had OBX|1|TX|AAAAA|BBBBBBB|Observation Text~~Observation Text|, Mirth is parsing the incomming message as OBX|1|TX|AAAAA|BBBBBBB|Observation Text~Observation Text|.

    Any help greatly appreciated....

  • #2
    Re:Mirth dropping repeating ~ characters in OBX:5

    What version of Mirth are you using? Are you using the strict or non-strict parser? Do you have repetitions turned on?
    Thanks!
    Chris Lang

    Comment


    • #3
      Re:Mirth dropping repeating ~ characters in OBX:5

      We are using We are using 1.5.0.2272 with strict parsing, and I had not use I understand your question about repetitions.

      Comment


      • #4
        Re:Mirth dropping repeating ~ characters in OBX:5

        The strict parser is known to strip segments like that (which are technically invalid).

        If you switch to the non-strict parser, it will leave the messages as-is. You will have to re-write any mappings or transformations you have (the non strict parser and strict parser have a different syntax).
        Chris Lang

        Comment


        • #5
          Re:Mirth dropping repeating ~ characters in OBX:5

          What about the repetitions setting, should that be selected or left unselected on the transformations?

          One item to note, turned off strict parsing and now can see the duplicated ~~ on the source message. In our transformations we use ${message.rawData} but still see that the ~ is being stripped. Do we need to build a new channel and destinations?

          Thanks for the help.. We are getting closer.

          Post edited by: MBT766, at: 09/17/2007 09:10

          Comment


          • #6
            Re:Mirth dropping repeating ~ characters in OBX:5

            You need to turn off the strict parser on both the source and each destination. Turn on the use repeitions setting.
            Brendan Haverlock | Mirth Software Engineer | Mirth Corporation

            Comment

            Working...
            X