Announcement

Collapse
No announcement yet.

Error when deploying channel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when deploying channel

    I get this error when trying to deploy a channel

    org.mule.config.ConfigurationException: Failed to parse configuration resource "/home/manu/Mirth/conf/mule-config.xml" (org.mule.config.ConfigurationException)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:196)
    at com.webreach.mirth.server.Mirth.startMule(Mirth.ja va:229)
    at com.webreach.mirth.server.Mirth.restartMule(Mirth. java:186)
    at com.webreach.mirth.server.Mirth.run(Mirth.java:117 )
    Caused by: org.mule.config.ConfigurationException: Failed to parse configuration resource "/home/manu/Mirth/conf/mule-config.xml"
    at org.mule.config.builders.AbstractDigesterConfigura tion.process(AbstractDigesterConfiguration.java:12 1)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:202)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:194)
    ... 3 more
    Caused by: org.mule.umo.lifecycle.InitialisationException: Initialisation Failure:
    CHANNEL: ADT_A04_A08_IN
    CONNECTOR: therapyedge
    SCRIPT SOURCE: Transformer
    LINE NUMBER: 1
    LINE SOURCE: = validate('', '', new Array());
    DETAILS: syntax error
    at org.apache.commons.digester.Digester.createSAXExce ption(Digester.java:2919)
    at org.apache.commons.digester.Digester.createSAXExce ption(Digester.java:2945)
    at org.apache.commons.digester.Digester.endElement(Di gester.java:1133)
    at org.apache.xerces.parsers.AbstractSAXParser.endEle ment(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanEndElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl$FragmentContentDispatcher.dispatch(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanDocument(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
    at org.apache.xerces.parsers.AbstractSAXParser.parse( Unknown Source)
    at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser .parse(Unknown Source)
    at org.apache.commons.digester.Digester.parse(Digeste r.java:1685)
    at org.mule.config.builders.AbstractDigesterConfigura tion.process(AbstractDigesterConfiguration.java:11 9)
    ... 5 more

    I don't understand where the problem comes from. I validated all the javascript, there seems to be no error.
    Thank you for any help

    Post edited by: Bleupomme, at: 09/07/2007 03:51

  • #2
    Re:Error when deploying channel

    Do you have empty mapping? Can you post your channel? Thanks!
    Chris Lang

    Comment


    • #3
      Re:Error when deploying channel

      Actually I don't have an empty mapping

      Here is the channel. ADT_A04_A08_IN-d103bb11a03572b731ef4a98363009ad.xml (47118 bytes)

      Comment


      • #4
        Re:Error when deploying channel

        By the way I'm also having problems with saving the channel. Sometimes I save the channel but when I work on another channel and come back I notice the last changes have not been saved. Could both errors be related?

        Comment


        • #5
          Re:Error when deploying channel

          We're seeing this happening randomly and looking into the cause.
          Chris Lang

          Comment


          • #6
            Re:Error when deploying channel

            What should I do about the undeployable channel?

            Comment


            • #7
              Re:Error when deploying channel

              I just created a new channel and copied the code, the new channel works.
              I compared the xml export files for both channels. this was the difference:
              > <steps>
              > <com.webreach.mirth.model.Step>
              > <sequenceNumber>0</sequenceNumber>
              > <name></name>
              > <script> = validate(&apos;&apos;, &apos;&apos;, new Array());</script>
              > <type>Message Builder</type>
              > <data class="map">
              > <entry>
              > <string>Variable</string>
              > <string></string>
              > </entry>
              > <entry>
              > <string>DefaultValue</string>
              > <string></string>
              > </entry>
              > <entry>
              > <string>Mapping</string>
              > <string></string>
              > </entry>
              > <entry>
              > <string>RegularExpressions</string>
              > <list/>
              > </entry>
              > </data>
              > </com.webreach.mirth.model.Step>
              > </steps>
              I don't know where this came from, but that was probably the problem.
              The saving problem comes when you use ctrl-s to save the channel. The channel only gets saved the first time, after that the saves don't work anymore - you have to go back to the list of channels and select the channel again.

              Post edited by: Bleupomme, at: 09/11/2007 03:04

              Comment

              Working...
              X