Announcement

Collapse
No announcement yet.

file connector does not read ascii file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • file connector does not read ascii file

    Hello mirth comunity,

    I'm trying to do my first steps in using mirth 1.6.1.2750 as JBoss MBean with a channel using a file reader connector. The files are "clear text" HL7 2.2 messages with ISO-8859-1 encoding.

    Here is a sample:

    Code:
    MSH|^~\&|SAP-ISH|DG|System1|Test|19991217100040||ADT^A04|15013015|P|2.2
    EVN|A04|19991217100027
    PID|||03234234^9||Smith^Charlotte^^^^||19200819|F|||Smith-Str. 161^^City^^82312^DE||03421-88734|||W|RK
    PV1||I|ICU^^|||^^||^&&&&&&&&&&^^^^^|^&&&&&&&&&&^^^^^|||||^&&&&&&&&&&|||||0991039318^6|||||K|||||||||||||||IC|||||19991216080636|
    ZPA|2|B^KK||19991217095933
    In the dashboard I can see the the raw read message which looks like this:

    Code:
    TVNIfF5+XCZ8U0FQLUlTSHxER3xTeXN0ZW0xfFRlc3R8MTk5OTEyMTcxMDAwNDB8fEFEVF5BMDR8
    
    MTUwMTMwMTV8UHwyLjIKRVZOfEEwNHwxOTk5MTIxNzEwMDAyNwpQSUR8fHwwMzIzNDIzNF45fHxT
    
    bWl0aF5DaGFybG90dGVeXl5efHwxOTIwMDgxOXxGfHx8U21pdGgtU3RyLiAxNjFeXkNpdHleXjgy
    
    MzEyXkRFfHwwMzQyMS04ODczNHx8fFd8UksKUFYxfHxJfElDVV5efHx8Xl58fF4mJiYmJiYmJiYm
    
    Xl5eXl58XiYmJiYmJiYmJiZeXl5eXnx8fHx8XiYmJiYmJiYmJiZ8fHx8fDA5OTEwMzkzMTheNnx8
    
    fHx8S3x8fHx8fHx8fHx8fHx8fElDfHx8fHwxOTk5MTIxNjA4MDYzNnwKWlBBfDJ8Ql5LS3x8MTk5
    
    OTEyMTcwOTU5MzMK
    So somehow the message is not read in as is.

    The channel source is configured as follows:

    File Type: ASCII
    Encoding: ISO-8859-1

    Obviously the file reader does not work as I thought it would.

    Any help is appreciated.

    Regards.

  • #2
    Re:file connector does not read ascii file

    Hi,

    Are you sure that you have selected the File Type: ASCII? Because it works fine with ASCII setting but getting that same mess while binary is selected. So, check the file type.

    Comment


    • #3
      Re:file connector does not read ascii file

      Here is a snapshot of the connector settings.



      Post edited by: level420, at: 09/05/2007 04:31

      Comment


      • #4
        Re:file connector does not read ascii file

        Are you running mirth as standalone or as JBoss MBean?

        Comment


        • #5
          Re:file connector does not read ascii file

          Bah, misread your text, sorry. Yeah, Im using Mirth as standalone.

          Comment


          • #6
            Re:file connector does not read ascii file

            Using the standalone server this works!

            I think I should file a bug for this issue.

            Comment


            • #7
              Re:file connector does not read ascii file

              Try changing the encoding to Default.
              Chris Lang

              Comment


              • #8
                Re:file connector does not read ascii file

                chrisl wrote:
                Try changing the encoding to Default.
                I tried several setups including default character encoding with no success.

                After moving from running mirth as JBoss mbean to mirth standalone this works!

                So I suspect this is a problem with running mirth as JBoss mbean.

                Should I file a bug for this?

                Thank you for your help.

                Regards.

                Comment


                • #9
                  Re:file connector does not read ascii file

                  chrisl wrote:
                  Try changing the encoding to Default.
                  I tried several setups including default character encoding with no success.

                  After moving from running mirth as JBoss mbean to mirth standalone this works!

                  So I suspect this is a problem with running mirth as JBoss mbean.

                  Should I file a bug for this?

                  Thank you for your help.

                  Regards.

                  Comment


                  • #10
                    Re:file connector does not read ascii file

                    It sounds like an issue with the JBoss encoder, because Mirth is running in the JBoss JVM. Go ahead and report it as an issue and we will take a look at it.
                    Jacob Brauer
                    Director, Software Development
                    NextGen Healthcare

                    sigpic

                    Comment


                    • #11
                      Re:file connector does not read ascii file

                      jacobb wrote:
                      It sounds like an issue with the JBoss encoder, because Mirth is running in the JBoss JVM. Go ahead and report it as an issue and we will take a look at it.
                      I've created the issue http://www.mirthproject.org/communit...owse/MIRTH-524 for this problem.

                      Comment


                      • #12
                        Re:file connector does not read ascii file

                        Sorry, but I'm not able to reproduce the bug anymore.

                        After reviewing the circumstances under which the problem showed up I think the problem was not the channel definition, but a problem with the channel deployment.

                        I think I first created the channel with the default settings for the file reader which is reading binary files.

                        I tested that and saw the error in the dashboard of Mirth administrator. Then I had a look into the "Raw Message" tab within the channel messages where I saw the binary hex data.

                        After that I corrected the settings in the file reader to "ASCII" and encoding "ISO-8859-1", saved the channel and re-deployed it. I started again to copy a HL7 file in to the file readers folder.

                        There was no change. The error in the dashboard showed up again.

                        I think the problem was that somehow the new settings in channel did not get saved or the modified channel did not get deployed.

                        As for now this bug should be put into the "could not reproduce" state.

                        Sorry for the traffic and wasting your time.

                        Comment

                        Working...
                        X