Announcement

Collapse
No announcement yet.

Prefered Java version for Mirth

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Prefered Java version for Mirth

    Hi,

    I scanned the forums for which Java version to use with Mirth, but the answers are from early 2012.

    Is the recommendation still is to use Oracle Java?
    Are the issues with Java 1.7 resolved or shall we use 1.6 still?

    What about the Open JDK?

    I have installed and ran Mirth Connect with both the Open JDK and Oracles Java Embedded 1.7.0 without any issues, but I prefer to play it safe and go with the recommended environment to avoid future problems

  • #2
    What version of Mirth are you using?

    Comment


    • #3
      Sorry, we are using Mirth 2.2.1 for Unix / Linux.

      Comment


      • #4
        I believe the Java 7 issues were fixed in the 2.2 upgrade.

        Comment


        • #5
          Upgrading to MIRTH Connect 2.2 -- Java 7 Required?

          Cory,
          If we are upgrading to MIRTH Connect 2.2 is Java 7 a requirement?

          Thank you.

          Comment


          • #6
            Originally posted by thunter View Post
            Cory,
            If we are upgrading to MIRTH Connect 2.2 is Java 7 a requirement?

            Thank you.
            Nope, Java 7 is not required, 6 will work just fine.
            Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

            Nicholas Rupley
            Work: 949-237-6069
            Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


            - How do I foo?
            - You just bar.

            Comment


            • #7
              The current version of Mirth Connect on the site is 2.2.2. Last year when I went to Java 7 I had problems logging in. I didn't see that addressed in the release notes. Is Java 6 the preferred version or is 2.2.2 stable with Java 7?

              Greg

              Comment


              • #8
                Originally posted by GregD View Post
                The current version of Mirth Connect on the site is 2.2.2. Last year when I went to Java 7 I had problems logging in. I didn't see that addressed in the release notes. Is Java 6 the preferred version or is 2.2.2 stable with Java 7?

                Greg
                2.2.2 is stable with Java 7. However Java had some known issues from releases 7u5-10, so that may have been what you were experiencing.
                Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

                Nicholas Rupley
                Work: 949-237-6069
                Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


                - How do I foo?
                - You just bar.

                Comment


                • #9
                  Originally posted by GregD View Post
                  The current version of Mirth Connect on the site is 2.2.2. Last year when I went to Java 7 I had problems logging in. I didn't see that addressed in the release notes. Is Java 6 the preferred version or is 2.2.2 stable with Java 7?

                  Greg
                  Did you use the same .jnlp? Or did you create a new one?

                  If you are using the same .jnlp it won't work because it is calling the wrong version of Mirth.

                  Comment

                  Working...
                  X