Announcement

Collapse
No announcement yet.

centos 5 install error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • centos 5 install error

    I am trying to install Mirth 1.5 on a Centos 5 box. When I run ./mirth.sh I get the following error:

    # ./mirth.sh
    Exception in thread "main" java.lang.NoClassDefFoundError: java.util.concurrent.PriorityBlockingQueue
    at com.webreach.mirth.server.CommandQueue.<init>(Comm andQueue.java:33)
    at com.webreach.mirth.server.CommandQueue.getInstance (CommandQueue.java:43)
    at com.webreach.mirth.server.Mirth.<init>(Mirth.java: 66)
    at java.lang.Class.newInstance(libgcj.so.7rh)
    at com.webreach.mirth.server.launcher.Launcher.main(L auncher.java:38)

    I installed jdk-1.5.0_11 package. Am I missing something?

  • #2
    Re:centos 5 install error

    I solved my own problem. I found the following on the centos forum

    First, you need to install Sun's Java (at least the jre);

    http://java.sun.com/j2se/1.5.0/download.jsp

    Then you need to reconfigure the default java configuration, this is done as root or equivalent.
    The instructions are listed below (it is a bit long).

    First remove /var/lib/alternatives/java file by typing;

    rm /var/lib/alternatives/java

    When asked press the 'y' key,

    Now to create the new (corrected) alternatives file for java type
    the following commands;

    /usr/sbin/alternatives --install /usr/bin/java java /usr/lib/jvm/jre-1.4.2-gcj/bin/java 1

    /usr/sbin/alternatives --install /usr/bin/java java /usr/java/j2re1.5.0_06/bin/java 2

    /usr/sbin/alternatives --config java

    You should now see for example:

    There are 2 programs which provide 'java'.

    Selection Command
    -----------------------------------------------
    1 /usr/lib/jvm/jre-1.4.2-gcj/bin/java
    *+ 2 /usr/java/j2re1.5.0_06/bin/java

    Enter to keep the current selection[+], or type selection number:

    Type: <choose 1 or 2>

    In the example above java is already configured correctly [*+ 2] to
    use Sun's Java, no changes are needed, just press the Enter key here.
    If you have been following the instructions then you should have
    the same results (version numbers may be sightly different).

    Now type; /usr/sbin/alternatives --display java

    You should see for example;

    java - status is manual.
    link currently points to /usr/java/j2re1.5.0_06/bin/java
    /usr/lib/jvm/jre-1.4.2-gcj/bin/java - priority 1
    /usr/java/j2re1.5.0_06/bin/java - priority 2
    Current `best' version is /usr/java/j2re1.5.0_06/bin/java.


    At this point I tried running ./mirth.sh again and it started right up. I include the rest for anybody who might be interested.

    Next you might want to create (or edit) /etc/profile.d/java.sh
    file, example below;

    export JAVA_HOME="/usr/java/jre1.5.0_06/bin"
    export JAVA_PATH="$JAVA_HOME"
    export PATH="$PATH:$JAVA_HOME"

    When done creating or editing the file type;

    source /etc/profile.d/java.sh

    Now any user should be able to use the command;

    which java

    and the results should read something like;

    /usr/java/jre1.5.0_06/bin/java


    Also any user should be able to use the command;

    java -version

    and the results should read something like;

    java version "1.5.0_06"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
    Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_06-b05, mixed mode)

    Comment

    Working...
    X