Announcement

Collapse
No announcement yet.

How is "Send a Message" being used?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How is "Send a Message" being used?

    Hello,

    I built a channel that reads an xml from a local directory and then converts it to HL7 and send to a server. This works well if I build and place an xml file and put it in my local directory.

    However, I just found that there is an option of "send a message" when you right click on the channel. Then you see the window to allow you place an actual message in it. I copied and paste an xml message into this window, then click on "Process Message". I kind of expect this xml message will be sent through the source and to the destination. However, it instead gave me the following error:

    [2012-10-24 11:46:05,858] ERROR (com.mirth.connect.server.util.VMRouter:88): Unable to route: /opt/mirthconnect/appdata/queuestore/078c8cfd-a95b-45d1-b2dc-afb404ef46aa/1008__ec048906-1df1-11e2-ac62-ff89fc1afad5.msg (No such file or directory)

    Does anyone know why I am getting such an error? How should this "send a message" option be used correctly? Do I need to set up source or destination in a particular way in order to allow me using this "send a message" feature?

    thanks!

    Jason
    Last edited by jasonhuang; 10-24-2012, 07:55 AM.

  • #2
    From the error message, it looks like Mirth is having trouble with the message and trying to Queue it, but failing because the folder it is trying to store the message in a folder that does not exist.

    I am not sure how it works with XML files, but I usually use the Send Message option on a channel when I am working with HL7 messages. I would just copy and paste the message and the channel would process it.

    Comment


    • #3
      could you share what type of source / destination setting you are using? In my case, the source is a file reader and the destination is a LLP sender. I guess we can forget about all the xml details. thanks.

      Comment


      • #4
        When I use the send message, I am usually using a LLP -> LLP channel or a LLP -> Database Writer. I think the fact that you are using a File Reader as your Source might be the issue when trying to use the Send Message feature.

        Comment


        • #5
          Basically, anything that happens in the File Reader is before the channel actually receives any messages (id est before the preprocessor). So if anything special is happening (like batching), that will not occur when you use the Send Message dialog (which basically just sends a message directly to the preprocessor of the channel).

          I wouldn't think that the error you're seeing has anything to do with the Send Message dialog per se, but who knows... Can you post your channel here?
          Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

          Nicholas Rupley
          Work: 949-237-6069
          Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


          - How do I foo?
          - You just bar.

          Comment


          • #6
            I've changed the source to a LLP listener but still get the same error when I copy/past the following xml message and click on "process message":

            <RegisterPt>
            <PatientIdentifier>2051</PatientIdentifier>
            <LastName>Test</LastName>
            <FirstName>Three</FirstName>
            <DatetimeOfBirth>19611121</DatetimeOfBirth>
            <Sex>M</Sex>
            <SSN>999991111</SSN>
            </RegisterPt>

            I've attached my channel and hopefully someone can help to figure out why the "send a message" feature doesn't work for me...

            thanks!
            Attached Files

            Comment


            • #7
              Try putting this at the top of the XML message before you send it:

              Code:
              <?xml version="1.0"?>

              Comment


              • #8
                Looking at the error again: "Unable to route: /opt/mirthconnect/appdata/queuestore/078c8cfd-a95b-45d1-b2dc-afb404ef46aa/1008__ec048906-1df1-11e2-ac62-ff89fc1afad5.msg (No such file or directory)"

                This kind of complains about not being able to create the msg file. I checked my installation and then change the permission of the Mirth specific folder to allow Mirth to write file in that directory. Now it works..

                Thanks all.

                Comment


                • #9
                  I really do appreciate you coming back here and stating what the problem was. You just saved me a day here, Jason.

                  Comment

                  Working...
                  X