Announcement

Collapse

NextGen (Mirth) Connect 3.10.0 Released!

NextGen (Mirth) Connect 3.10.0 is now available as an appliance update and on our GitHub page. This release includes better SQL Server database support, security improvements through fixes and library updates, and improvements for the Advanced Clustering plugin with a focus on improving performance of many of the tasks that are carried out on a frequent interval. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Mirth 1.5 - Cannot deploy on server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth 1.5 - Cannot deploy on server

    I have two machines that I'm running Mirth on. One is a test copy on my machine, and the other is the "live" server which has our connection to the company sending the HL7 file. I've been testing a transformer on my machine which is working perfectly with a File Reader source and Database Writer destination. However, I can't get the server to deploy it's channel; I'm getting an error of 'Failed to parse configuration resource "C:\Program Files\Mirth\conf\mule-config.xml"'.

    I have been able to successfully receive on the server, before I made the current version of the transformer. However, my test machine can deploy the channel just fine. The server is running a clean version of Mirth; I uninstalled, deleted the folder, and reinstalled, then rebuilt the channel manually, except for the database query and the transformer.

    I've been able to use the mule-config.xml file on my local copy of Mirth as well, so I'm finding myself stumped. Both machines are running Java build 1.6.0_02-b06. My machine is Windows XP, the server is Windows 2000.

    The attached text file contains both the config file and my channel. merged_xml.txt (338230 bytes)

  • #2
    Re:Mirth 1.5 - Cannot deploy on server

    I saved the contents under "[HL7.xml - import channel]" in your attachment as a separate file and imported to Mirth 1.5 running on Windows Server 2000 SP4, JRE 1.6 Update 1. The channel deployed fine except for the problem related to the IP address which is expected.

    ERROR 2007-07-25 09:52:52,531 [Thread-0] org.mule.impl.model.seda.SedaModel: Error starting component [a7715472-165a-40da-8f58-66b131e32924]
    org.mule.providers.FatalConnectException: ReconnectStrategy "org.mule.providers.SingleAttemptConnectionStrateg y" failed to reconnect receiver on endpoint "mllp://172.27.174.34:9726"

    I have attached the imported channel that deployed fine.

    NOTE: When I change the IP address to 127.0.0.1 the channel deployed with no errors.

    On your test box, delete the existing channel and import the attached channel file. If it works fine, try the same on the Windows Server 2000 box.

    Hope this helps! Import_Channel_HL7.xml (318213 bytes)

    Comment


    • #3
      Re:Mirth 1.5 - Cannot deploy on server

      Thank you for the help; unfortunately, the new file didn't perform any differently on the server machine than before. It looks like there was something going on at the server end, and the latest uninstall, cleanup, and reinstall seems to have done the trick. So, everything's working now, whatever the problem was.

      Comment

      Working...
      X