Announcement

Collapse

NextGen (Mirth) Connect 3.10.0 Released!

NextGen (Mirth) Connect 3.10.0 is now available as an appliance update and on our GitHub page. This release includes better SQL Server database support, security improvements through fixes and library updates, and improvements for the Advanced Clustering plugin with a focus on improving performance of many of the tasks that are carried out on a frequent interval. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

RMI port number change

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RMI port number change

    I am using Mirth 1.5.0.2272 on Windows Vista with JRE 1.5.0_11 and MSSQL 2005.

    I am also running JBoss AS on this machine and that uses up the 1099 port. I am trying to change the RMI port number in Mirth but am unsuccessful at it. These changes had worked in previous versions of Mirth. I have made the following changes to mule-boot.xml:

    Code:
    	<agents>
    		<agent name="RMI"
    			className="org.mule.management.agents.RmiRegistryAgent">
    			<properties>
                                        <property name="serverUri" value="rmi://localhost:1096" />
                            </properties>
                    </agent>
    
    		<agent name="JMX" className="org.mule.management.agents.JmxAgent">
    			<properties>
    				<property name="connectorServerUrl"
    					value="service:jmx:rmi:///jndi/rmi://localhost:1096/server" />
    
    				<map name="connectorServerProperties">
    					<property name="jmx.remote.jndi.rebind" value="true" />
    				</map>
    			</properties>
    		</agent>
    	</agents>
    and to mirth.properties
    Code:
    jmx.url=service\:jmx\:rmi\:///jndi/rmi\://localhost\:1096/server
    mule-config.xml is sticking to port 1099. I checked to make sure mule-config.xml is getting generated at start up.

    This is the exception I am getting.

    Code:
    WARN  2007-07-03 21:30:03,913 [Thread-0] com.webreach.mirth.server.Mirth: Error deploying channels.
    org.mule.config.ConfigurationException: MuleManager Failed to initialise (org.mule.config.ConfigurationException)
            at org.mule.config.builders.MuleXmlConfigurationBuilder.configure(MuleXmlConfigurationBuilder.java:196)
            at com.webreach.mirth.server.Mirth.startMule(Mirth.java:178)
            at com.webreach.mirth.server.Mirth.run(Mirth.java:110)
    Caused by: org.mule.config.ConfigurationException: MuleManager Failed to initialise
            at org.mule.config.builders.MuleXmlConfigurationBuilder.configure(MuleXmlConfigurationBuilder.java:209)
            at org.mule.config.builders.MuleXmlConfigurationBuilder.configure(MuleXmlConfigurationBuilder.java:194)
            ... 2 more
    Caused by: org.mule.management.agents.JmxManagementException: Failed to start Jmx Connector
            at org.mule.management.agents.JmxAgent.start(JmxAgent.java:188)
            at org.mule.MuleManager.startAgents(MuleManager.java:1082)
            at org.mule.MuleManager.start(MuleManager.java:729)
            at org.mule.config.builders.MuleXmlConfigurationBuilder.configure(MuleXmlConfigurationBuilder.java:207)
            ... 3 more
    Caused by: java.io.IOException: Cannot bind to URL [rmi://localhost:1099/server]: javax.naming.CommunicationException [R
    oot exception is java.rmi.ConnectIOException: non-JRMP server at remote endpoint]
            at javax.management.remote.rmi.RMIConnectorServer.newIOException(Unknown Source)
            at javax.management.remote.rmi.RMIConnectorServer.start(Unknown Source)
            at org.mule.management.agents.JmxAgent.start(JmxAgent.java:186)
            ... 6 more
    Caused by: javax.naming.CommunicationException [Root exception is java.rmi.ConnectIOException: non-JRMP server at remote
     endpoint]
            at com.sun.jndi.rmi.registry.RegistryContext.rebind(Unknown Source)
            at com.sun.jndi.toolkit.url.GenericURLContext.rebind(Unknown Source)
            at javax.naming.InitialContext.rebind(Unknown Source)
            at javax.management.remote.rmi.RMIConnectorServer.bind(Unknown Source)
            ... 8 more
    Caused by: java.rmi.ConnectIOException: non-JRMP server at remote endpoint
            at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
            at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
            at sun.rmi.server.UnicastRef.newCall(Unknown Source)
            at sun.rmi.registry.RegistryImpl_Stub.rebind(Unknown Source)
            ... 12 more
    Mirth 1.5.0.2272 (May 24, 2007) server successfully started: Tue Jul 03 21:30:04 EDT 2007
    This product includes software developed by SymphonySoft Limited (http://www.symphonysoft.com) and its contributors.
    Running Java 1.5.0_11 on Windows Vista (6.0, x86)

  • #2
    Re:RMI port number change

    Try to deploy the channels. You need to deploy to generate a new mule.conf

    Comment


    • #3
      Re:RMI port number change

      Alberto is right. After you change the mirth.properties and mule-boot.xml, you should re-deploy your channels. This will generate a new mule-conf.xml.

      This jmx port problem has already been fixed in the repository and will be included in the next release of Mirth. For now, you will have to change it in those three places you did. Later, it will only involve changing mirth.properties.

      Jacob
      Jacob Brauer
      Director, Software Development
      NextGen Healthcare

      sigpic

      Comment


      • #4
        Re:RMI port number change

        Thank you very much. That fixed the problem.

        Comment

        Working...
        X