Announcement

Collapse

NextGen (Mirth) Connect 3.10.0 Released!

NextGen (Mirth) Connect 3.10.0 is now available as an appliance update and on our GitHub page. This release includes better SQL Server database support, security improvements through fixes and library updates, and improvements for the Advanced Clustering plugin with a focus on improving performance of many of the tasks that are carried out on a frequent interval. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

LLP Channel Stops Listening - Help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LLP Channel Stops Listening - Help!

    I am trying to figure this one out, but so far no luck, everything seems to be correct on the channel setup. Mirth Build 1.5.0.2272

    I have setup an HL7 LLP listener. There are times when the channel stops listening. You send a message to the channel but it won't take it. No erros messages. The sender just sits waiting for the ACK. The status shows started. I need to stop the channel and then start it for it to work. There are times when the channel is listenning (I know this by telneting the port) but with the same behavior -not taking any incoming messages.

    Settings: Keep connection Open = No
    Receive Timeout = 500000 ( I increased the timeout )
    Use Strict LLP Validation = No
    Wait for End of MEssage Char = No
    Send ACK = Yes

    I am not experiencing this issue on any other channel.

    Any help would be greatly appreciated.

  • #2
    Re:LLP Channel Stops Listening - Help!

    We have noticed this with certain senders and/or settings and are working on figuring out what the problem is and issuing a patch. Could you please let me know what sending facility (sender) you are using to send the messages to Mirth? Also, if you can post an export of your channel that may be useful.

    Jacob
    Jacob Brauer
    Director, Software Development
    NextGen Healthcare

    sigpic

    Comment


    • #3
      Re:LLP Channel Stops Listening - Help!

      I am not sure what the sending system is. But like I said, we receive a ton of messages with no issues and then the channel stops listening OR Mirth stops digesting messages and sending back ACK's. We were almost ready for production with this client, but if I can't figure this one out. I will have to try another way, at least until a patch is out. Below is the channel:

      <com.webreach.mirth.model.Channel>
      <id>37c9aae3-8a73-4da1-9cf2-1c1567b9c401</id>
      <name>HL7 ADT Inbound from ISOL</name>
      <description></description>
      <enabled>true</enabled>
      <version>1.5.0.2272</version>
      <revision>9</revision>
      <sourceConnector>
      <name>sourceConnector</name>
      <properties>
      <property name="receiveTimeout">5000000</property>
      <property name="ackMsgError">An Error Occured Processing Message.</property>
      <property name="ackMsgSuccessful"></property>
      <property name="messageStart">0x0B</property>
      <property name="messageEnd">0x1C</property>
      <property name="waitForEndOfMessageCharacter">0</property>
      <property name="bufferSize">65536</property>
      <property name="ackCodeError">AE</property>
      <property name="ackIP">...</property>
      <property name="host">10.10.10.101</property>
      <property name="responseFromTransformer">0</property>
      <property name="ackOnNewConnection">0</property>
      <property name="ackCodeRejected">AR</property>
      <property name="tcpProtocolClassName">org.mule.providers.tcp .protocols.TcpProtocol</property>
      <property name="sendACK">1</property>
      <property name="port">8000</property>
      <property name="ackMsgRejected">Message Rejected.</property>
      <property name="ackCodeSuccessful">AA</property>
      <property name="ackPort"></property>
      <property name="useStrictLLP">0</property>
      <property name="charEncoding">hex</property>
      <property name="DataType">LLP Listener</property>
      <property name="responseValue">None</property>
      <property name="charsetEncoding">DEFAULT_ENCODING</property>
      <property name="keepSendSocketOpen">0</property>
      <property name="checkMSH15">0</property>
      <property name="recordSeparator">0x0D</property>
      <property name="segmentEnd">0x0D</property>
      </properties>
      <transformer>
      <steps/>
      <inboundProtocol>HL7V2</inboundProtocol>
      <outboundProtocol>HL7V2</outboundProtocol>
      </transformer>
      <filter>
      <rules/>
      </filter>
      <transportName>LLP Listener</transportName>
      <mode>SOURCE</mode>
      </sourceConnector>
      <destinationConnectors>
      <com.webreach.mirth.model.Connector>
      <name>Destination HL7</name>
      <properties>
      <property name="binary">0</property>
      <property name="charsetEncoding">DEFAULT_ENCODING</property>
      <property name="host">F:/MirthMessages/ISol/RIS_ADT_Inbound/PreQueue</property>
      <property name="outputPattern">${UUID}.hl7</property>
      <property name="DataType">File Writer</property>
      <property name="template">${message.rawData}</property>
      <property name="outputAppend">0</property>
      </properties>
      <transformer>
      <steps/>
      <inboundProtocol>HL7V2</inboundProtocol>
      <outboundProtocol>HL7V2</outboundProtocol>
      </transformer>
      <filter>
      <rules/>
      </filter>
      <transportName>File Writer</transportName>
      <mode>DESTINATION</mode>
      </com.webreach.mirth.model.Connector>
      <com.webreach.mirth.model.Connector>
      <name>Destination XML</name>
      <properties>
      <property name="binary">0</property>
      <property name="charsetEncoding">DEFAULT_ENCODING</property>
      <property name="host">F:/MirthMessages/ISol/RIS_ADT_Inbound/PreQueue</property>
      <property name="outputPattern">${UUID}.xml</property>
      <property name="DataType">File Writer</property>
      <property name="template">${message.transformedData}</property>
      <property name="outputAppend">0</property>
      </properties>
      <transformer>
      <steps/>
      <inboundProtocol>HL7V2</inboundProtocol>
      <outboundProtocol>HL7V2</outboundProtocol>
      </transformer>
      <filter>
      <rules/>
      </filter>
      <transportName>File Writer</transportName>
      <mode>DESTINATION</mode>
      </com.webreach.mirth.model.Connector>
      </destinationConnectors>
      <properties>
      <property name="synchronous">true</property>
      <property name="removeNamespace">true</property>
      <property name="encryptData">false</property>
      <property name="store_messages">true</property>
      <property name="dont_store_filtered">false</property>
      <property name="initialState">started</property>
      <property name="max_message_age">-1</property>
      <property name="transactional">false</property>
      <property name="error_messages_only">false</property>
      </properties>
      <preprocessingScript>// Modify the message variable below to pre process data&#x0D;
      return message;</preprocessingScript>
      </com.webreach.mirth.model.Channel>

      Comment


      • #4
        Re:LLP Channel Stops Listening - Help!

        Could you try turning on "Use strict LLP validation" and see if you still get the same problem? Thanks.

        Jacob
        Jacob Brauer
        Director, Software Development
        NextGen Healthcare

        sigpic

        Comment


        • #5
          Re:LLP Channel Stops Listening - Help!

          You probably may seen the following post by Chris,
          http://www.mirthproject.org/index.ph...d=2686&catid=2

          Receiving Messages from GE Centricity/MIK
          Summary Tab: Strip namespace from messages [Checked]
          Source Tab:
          Receive Timeout (ms): 5000000
          Keep Connection Open: Yes
          Use Strict LLP Validation: No
          Wait for End of Message Char: Yes

          An update from another user was, "Receive Timeout (ms): 0" would make it never time out.
          The above settings helped to process all messages from the host by Mirth 1.5 LLP channel.
          But like I said, we receive a ton of messages with no issues and then the channel stops listening OR Mirth stops digesting messages and sending back ACK's
          "Keep connection Open = Yes", setting should typically take care of this type of problem.

          Another option (just to troubleshoot) would be to try turning off ACK on both sides (host and also in the Mirth LLP channel).

          Hope it helps!

          Comment


          • #6
            Re:LLP Channel Stops Listening - Help!

            I tried it before with Keep Connection Open: "Yes" and then later "No" and had the same issue. I have the channel up for 3 days now since last interruption, with no issues and the only change that I made was turning on "Use strict LLP validation". I will keep checking...

            Comment


            • #7
              Re:LLP Channel Stops Listening - Help!

              Good news! Let me know if it stops working again.

              Jacob
              Jacob Brauer
              Director, Software Development
              NextGen Healthcare

              sigpic

              Comment


              • #8
                Re:LLP Channel Stops Listening - Help!

                mbarroso, you should also turn your "Keep Connection Open" off. Having this option on can eventually cause your channel to stop receiving messages. This is a bug and the option will be removed in the next Mirth version. Instead, if you would like to keep your connection open you should simply set your receive timeout to 0 (infinite).

                Jacob
                Jacob Brauer
                Director, Software Development
                NextGen Healthcare

                sigpic

                Comment

                Working...
                X