Announcement

Collapse
No announcement yet.

Error:source_connector._mllpEndpoint#-970.receiver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • anna
    replied
    Re:Error:source_connector._mllpEndpoint#-970.receiver

    you can get to me on joeanna82(at)gmail(dot)com

    Leave a comment:


  • nshaik
    replied
    Re:Error:source_connector._mllpEndpoint#-970.receiver

    Anna,

    Glad to know it is working!

    In your initial post you menitoned that you were able to receive HL7 from a test VOE VistA setup.

    I'm trying to get a Mirth interface setup for VOE VistA (a.k.a WorldVistA). When you get a chance, will it be possible for you to post information about VOE VistA setup and Mirth Interface? (the company that did the VOE VistA implementation, support etc.)

    If you prefer discussing this by email, you may either post your email address here or with your permission I can try to get it from the Mirth team.

    Thans in advance for your help!

    Leave a comment:


  • anna
    replied
    Re:Error:source_connector._mllpEndpoint#-970.recei

    Thank you Nshaik and Chris, the changes on the MIK side seemd to have solved the problem.
    Regards
    Anna

    Leave a comment:


  • anna
    replied
    Re:Error:source_connector._mllpEndpoint#-970.recei

    I'm working on the Mirth side. Not too sure of the setting done in MIK. Try and have them checked out. But no messages have come in at all!

    Have attached my channel. I think all's well.

    INCOMING.xml (4908 bytes)

    Post edited by: anna, at: 06/09/2007 01:11

    Post edited by: anna, at: 06/09/2007 01:12

    Leave a comment:


  • chrisl
    replied
    Re:Error:source_connector._mllpEndpoint#-970.recei

    The error is harmless, but we have addressed it in 1.5.1. You should still receive messages fine.

    Post edited by: chrisl, at: 06/08/2007 10:13

    Leave a comment:


  • nshaik
    replied
    Re:Error:source_connector._mllpEndpoint#-970.receiver

    >>> Is this error caused due to MIK sending different start, end of message, etc. characters? <<<

    You should be able to check this on the MIK configuration screen

    The MIK setup requires:

    Code:
    Beginning of message squence string: \\x0B
    End of message sequence string: \\x1C\\x0D

    Leave a comment:


  • anna
    replied
    Re:Error:source_connector._mllpEndpoint#-970.receiver

    Also I have configured the channel taking into consideration the thread "Receiving Messages from GE Centricity/MIK by chrisl" under "Spotlights"

    Thanks

    Leave a comment:


  • anna
    started a topic Error:source_connector._mllpEndpoint#-970.receiver

    Error:source_connector._mllpEndpoint#-970.receiver

    I have a channel configured to receive HL7 for LLP Listener. I have been able to receive HL7 from a test VOE VistA setup as well. MIK is sending messages to this channel but I get the following error: What does this refer to?

    FATAL 2007-06-06 23:26:32,051 [212e0968-39c7-42b0-a393-e77462fe7a90_source_connector._mllpEndpoint#-943234270.receiver.3] org.mule.impl.DefaultComponentExceptionStrategy: The Default Component Exception Strategy has been invoked but there is no current event on the context
    FATAL 2007-06-06 23:26:32,051 [212e0968-39c7-42b0-a393-e77462fe7a90_source_connector._mllpEndpoint#-943234270.receiver.3] org.mule.impl.DefaultComponentExceptionStrategy: The error is: sleep interrupted
    java.lang.InterruptedException: sleep interrupted
    at java.lang.Thread.sleep(Native Method)
    at com.webreach.mirth.server.mule.providers.mllp.Mllp MessageReceiver$TcpWorker.run(MllpMessageReceiver. java:278)
    at org.mule.impl.work.WorkerContext.run(WorkerContext .java:290)
    at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor$Worker.runTask(ThreadPoolExecutor. java:650)
    at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor$Worker.run(ThreadPoolExecutor.java :675)
    at java.lang.Thread.run(Unknown Source)

    Also I have set, in my channel

    1. Start of message Char: 0x0B
    2. End of message Char: 0x1C
    3. Record Separator Char: 0x0D
    4. End of Segment Char: 0x0D

    Is this error caused due to MIK sending different start, end of message, etc. characters?
Working...
X