Announcement

Collapse

NextGen (Mirth) Connect 3.10.0 Released!

NextGen (Mirth) Connect 3.10.0 is now available as an appliance update and on our GitHub page. This release includes better SQL Server database support, security improvements through fixes and library updates, and improvements for the Advanced Clustering plugin with a focus on improving performance of many of the tasks that are carried out on a frequent interval. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

1.5 was reinstalled, but i keep getting errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.5 was reinstalled, but i keep getting errors

    Java version is 6 on a ubuntu 6.06 box.
    After installing twice, I don't know what would be the problem. Derby works, but can't deploy. 1.4 was working on th same box before.

    Suggestions are welcome.

    Code:
    Could not retrieve latest configuration.
    java.sql.SQLException: Unknown database 'mirthdb'
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2928)
            at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:771)
            at com.mysql.jdbc.MysqlIO.secureAuth411(MysqlIO.java:3664)
            at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:1176)
            at com.mysql.jdbc.Connection.createNewIO(Connection.java:2558)
            at com.mysql.jdbc.Connection.<init>(Connection.java:1485)
            at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:266)
            at java.sql.DriverManager.getConnection(DriverManager.java:582)
            at java.sql.DriverManager.getConnection(DriverManager.java:185)
            at com.ibatis.common.jdbc.SimpleDataSource.popConnection(SimpleDataSource.java:580)
            at com.ibatis.common.jdbc.SimpleDataSource.getConnection(SimpleDataSource.java:222)
            at com.ibatis.sqlmap.engine.transaction.jdbc.JdbcTransaction.init(JdbcTransaction.java:48)
            at com.ibatis.sqlmap.engine.transaction.jdbc.JdbcTransaction.getConnection(JdbcTransaction.java:89)
            at com.ibatis.sqlmap.engine.mapping.statement.GeneralStatement.executeQueryForObject(GeneralStatement.java:104)
            at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.queryForObject(SqlMapExecutorDelegate.java:566)
            at com.ibatis.sqlmap.engine.impl.SqlMapExecutorDelegate.queryForObject(SqlMapExecutorDelegate.java:541)
            at com.ibatis.sqlmap.engine.impl.SqlMapSessionImpl.queryForObject(SqlMapSessionImpl.java:106)
            at com.ibatis.sqlmap.engine.impl.SqlMapSessionImpl.queryForObject(SqlMapSessionImpl.java:110)
            at com.ibatis.sqlmap.engine.impl.SqlMapClientImpl.queryForObject(SqlMapClientImpl.java:87)
            at com.webreach.mirth.server.controllers.ConfigurationController.getLatestConfiguration(ConfigurationController.java:332)
            at com.webreach.mirth.server.Mirth.startMule(Mirth.java:171)
            at com.webreach.mirth.server.Mirth.run(Mirth.java:110)
    Post edited by: gazetaj, at: 06/01/2007 09:09

  • #2
    Re:1.5 was reinstalled, but i keep getting errors

    Ok. I tried downloading the version 1.4 and doing the same exact tests to it instead the problem remains. I do not have a stack trace for the 1.4. I will try now to get java 1.5 re-installed onto that box and hopefully that should give some more clues .

    In other words it might relate to the jdk and not the code itself.

    I will post other tests. here.

    Comment


    • #3
      Re:1.5 was reinstalled, but i keep getting errors

      Make sure 1.4 is fully removed (do not extract to the same directory), and run the creation script against your mysql database again. Also, put your database properties back in the SQL properties files and set mirth.properties to use mysql. Then start Mirth, and webstart the client.
      Brendan Haverlock | Mirth Software Engineer | Mirth Corporation

      Comment


      • #4
        Re:1.5 was reinstalled, but i keep getting errors

        I'll do that again, but I am pretty sure that I have them into 2 separate directories. I am just starting either Mirth 1.5 or 1.4 on a Java runtime 1.6.

        Everything works fine until I try to deploy the channels and nothing appears on the status.

        But I will test again!

        Comment


        • #5
          Re:1.5 was reinstalled, but i keep getting errors

          Check the System Events to see why the channels didn't deploy.
          Brendan Haverlock | Mirth Software Engineer | Mirth Corporation

          Comment


          • #6
            Re:1.5 was reinstalled, but i keep getting errors

            Thanks to every one. The deployment event was successful, but neither mirth 1.4 or the 1.5 were able to detect that there was a memory problem. Well once the mirth.sh and wrapper.conf were changed. That solved the problem.

            Thank you.

            Comment

            Working...
            X