Announcement

Collapse
No announcement yet.

Formatting Transcription Free-text

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Formatting Transcription Free-text

    We need to import formatted free text. The transcription agency is using "~" as the carriage return line feed indicator. So a piece of text looks like

    CC: John W. Smith, M.D.~PRIMARY CARE PHYSICIAN:~Alice W. Jones, M.D.~HISTORY AND HOSPITAL COURSE:~The patient

    which Mirth imports as

    <OBX.5 xmlns="urn:hl7-org:v2xml">CC: John W. Smith, M.D.</OBX.5>\n<OBX.5 xmlns="urn:hl7-org:v2xml">PRIMARY CARE PHYSICIAN:</OBX.5>\n<OBX.5 xmlns="urn:hl7-org:v2xml">Alice W. Jones, M.D.</OBX.5>\n<OBX.5 xmlns="urn:hl7-org:v2xml">HISTORY AND HOSPITAL COURSE:</OBX.5>\n<OBX.5 xmlns="urn:hl7-org:v2xml">The patient

    Of course we cannot send this tagged text to the physician. How do we use Mirth to format the text to:

    CC: John W. Smith, M.D.
    PRIMARY CARE PHYSICIAN:
    Alice W. Jones, M.D.
    HISTORY AND HOSPITAL COURSE:
    The patient



  • #2
    Re: Formatting Transcription Free-text

    In the Summary Tab / Preprocessing Script section, you could use JavaScript replace function to replace the character with \n. You may need to replace the ~ in header portion "MSH|^~\&" first and then replace ~ in the transcription text. Hope it helps!

    Comment


    • #3
      Re: Formatting Transcription Free-text

      You may need to temporarily replace the ~ in header portion "MSH|^~\&" to something like "MSH|^*\&" first, replace ~ in the transcription text to \n, and then replace "MSH|^*\&" back to "MSH|^~\&". Hope it helps!

      Comment


      • #4
        Re: Formatting Transcription Free-text

        You can also turn off the strict parser - make sure you go to each transformer and go to the Incoming Data/Outgoing Data tabs, hit Properties and uncheck "use strict parser". You will have to re-define your mappings.

        -Chris
        Chris Lang

        Comment

        Working...
        X