No announcement yet.

Problems with HTML to RTF conversion

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with HTML to RTF conversion

    Hi Everybody !

    For my project, I have to convert an HTML file into a RTF file.
    I found that this can be made in a "Document Writer" destination and it works ... partially.
    My RTF file is well created in the directory specified but when I open it, I see that all my tag <style> is displayed in plain text on the top of my document.

    Have you any idea on how to solve this problem ?

    And I think the conversion is quite long (about 2 minutes for a small html). Is it normal ?

    Thank you in advance for your answers.

    Have a nice day.

  • #2
    Have you tried the same code, but instead output a PDF file?

    Or try changing it from Document Writer to File Writer and see if that helps any.


    • #3
      I didn't wrote any piece of code for that...
      I created a new destination in Mirth and used the "Document Writer" Connector Type.
      I filled in the fields "Directory" and "File Name", I checked RTF and in the field "template", I put the "${message.rawData}" variable which contains my HTML.

      What I want to know is : How to keep my HTML structure into the RTF File ?

      I also tested with PDF and it's worse because I lost my tables. Anyway I don't want to convert in PDF.

      Thank you for your time.


      • #4
        Have you any idea how to solve this problem ?

        Thank you for your answers.


        • #5
          This is a stab in the dark as I've never worked with them, but could an HTTP listener help?

          From the settings it appears to give you options as to what to break down and parse.

          Also, use message.encodedData I think.
          I can be reached through gmail and Google Talk using davidrothbauer at gmail dot com

          Test all my code suggestions prior to implementation


          • #6
            Originally posted by glucoz View Post
            Have you any idea how to solve this problem ?

            Thank you for your answers.
            Did you find any resolution to this issue? I am having similar problems (using Mirth 3.6)