Announcement

Collapse
No announcement yet.

TCP Listener Connects, LLP Listerner Does Not

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TCP Listener Connects, LLP Listerner Does Not

    I have been trying to set up an LLP listener, but I cannot get it to connect to the server. I have succesfully connected with a TCP listener using the same settings. It would seem they should work with the same settings. I don't know what I'm doing wrong. I know the TCP listener works because I have sent it a message from HL7Comm and have received a simple AO8 message. I have included my channels as atacments.


    It seems as if the LLP cannot open the socket/port (I don't know the exact terminology). If I use netstat -a when the LLP is runing there is nothing. If I use netstat -a with TCP I see the socket. Also, if I run the TCP listener and then go into the channels and test the LLP connection, the LLP listener can connect.
    Attached Files
    Last edited by SQLGuy; 11-24-2010, 02:51 PM.

  • #2
    Solved the Problem

    I figured out the problem and can now recieve messages and send an ACK. The mistake I was making was in the LLP listener. I had it set to client. I needed to set it to server. That solved the problem.

    I founded the answere reading a different post about ACKs http://www.mirthcorp.com/community/f...k+tcp+listener

    Attached is my basic working channel
    Attached Files

    Comment

    Working...
    X