Announcement

Collapse
No announcement yet.

Warning on webservice listener

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning on webservice listener

    Hi all,

    after upgrading to Mirth 2.0 and rewriting the envelope from my provider app, webservice works correctly but throws this messages:

    com.sun.xml.internal.ws.transport.http.HttpAdapter fixQuotesAroundSoapAction

    This fixQuotesAroundSoapAction, seems a function to arrange soapaction parameter when does not start with \" or ends with \".

    Inside this function, mirth throws this message to the console:

    Received WS-I BP non-conformant Unquoted SoapAction HTTP header: http://tempuri.org/acceptMessage

    As you can see soapaction=http://tempuri.org/acceptMessage, and the fixQuotesAroundSoapAction function adds \" at first and last position of the soapaction.

    At this point, how can I avoid this messages?. My provider, AFAIK, does not send soapaction...

    Thanks in advance for your help,

    Ricard Bernat

  • #2
    Hi again,

    after some check, I decided to recreate the channel from the scratch, but with no luck again. The message is processed correctly and all destinations reached but this messages appear at the console:

    [2010-11-26 18:14:58,352] ERROR (Server Error:146): 26-nov-2010 18:14:58 com.sun.xml.internal.ws.transport.http.HttpAdapter fixQuotesAroundSoapAction

    and few ms later:

    [2010-11-26 18:14:58,368] ERROR (Server Error:146): ADVERTENCIA: Received WS-I BP non-conformant Unquoted SoapAction HTTP header: http://tempuri.org/acceptMessage

    For this channel, this condition could be acceptable, but for high load channels like laboratories are not.

    Somebody could help me?.

    Thanks for your help,

    Ricard Bernat

    Comment


    • #3
      Hi all,

      after some help seems that this error is produced by SOAPAction header. At this point, and due to in 1.1 specs for webservices this is not a required header, can I disable processing this header?.

      If this is not possible, how can I disable only this kind of errors from being reported to the dashboard?.

      Any hint will be welcome!

      Ricard Bernat

      Comment

      Working...
      X