Announcement

Collapse
No announcement yet.

Channel save problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Channel save problem

    Using mirth-1.1.0 (on Windows XP) I am having a problem with the "Getting Started with Mirth" procedure. ( I have the postgreSQL 8.1 database installed)

    The error occurs on the following step (Save changes):

    2) Click Summary Tab

    a. Check the Enabled button. This will allow this channel to be published.

    b. Click Save Changes in the Channel Tasks Window

    The client application pops up a windows which says:
    "There was a problem with one or more of your connectors. Please validate all of your connectors to find the problem."

    The channel cannot be enabled because of this problem.

    Any feedback on this problem would be appreciated.


    Below is some DEBUG logging that was turned on:

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: executing prepared statement:
    insert into channels (id, channel_name, channel_data) values (?, ?, ?)

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=1, value=5

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=2, value=chan2

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=3, value=<com.webreach.mirth.model.Channel>
    <id>5</id>
    <name>chan2</name>
    <description></description>
    <enabled>false</enabled>
    <version>1.1.0</version>
    <revision>0</revision>
    <direction>INBOUND</direction>
    <mode>BROADCAST</mode>
    <sourceConnector>
    <name>sourceConnector</name>
    <properties>
    <property name="checkFileAge" value="0"/>
    <property name="fileAge" value="0"/>
    <property name="pollingFrequency" value="1000"/>
    <property name="autoDelete" value="0"/>
    <property name="DataType" value="File Reader"/>
    <property name="moveToDirectory" value=""/>
    <property name="host" value=""/>
    <property name="moveToPattern" value=""/>
    </properties>
    <transformer>
    <steps/>
    </transformer>
    <filter>
    <rules/>
    </filter>
    <transportName>File Reader</transportName>
    </sourceConnector>
    <destinationConnectors>
    <com.webreach.mirth.model.Connector>
    <name>Destination 1</name>
    <properties>
    <property name="outputAppend" value="1"/>
    <property name="DataType" value="File Writer"/>
    <property name="outputPattern" value=""/>
    <property name="template" value=""/>
    <property name="host" value=""/>
    </properties>
    <transformer>
    <steps/>
    </transformer>
    <filter>
    <rules/>
    </filter>
    <transportName>File Writer</transportName>
    </com.webreach.mirth.model.Connector>
    </destinationConnectors>
    <properties>
    <property name="initialState" value="stopped"/>
    <property name="recv_xml_encoded" value="false"/>
    </properties>
    </com.webreach.mirth.model.Channel>

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: creating new database connection: address=jdbc:hsqldb:file:database/mirth, {user=sa, password=, shutdown=true}

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: executing prepared statement:
    insert into channel_statistics (channel_id, received, sent, errors) values (?, ?, ?, ?)

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=1, value=5

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=2, value=0

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=3, value=0

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: adding parameter: index=4, value=0

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: closing database connection

    DEBUG [SslListener0-1] com.webreach.mirth.server.util.DatabaseConnection: closing database connection

  • #2
    Re: Channel save problem

    This is a known issue with 1.1 - it does not like an empty DB password field. This has been addressed in 1.2.

    -Chris
    Chris Lang

    Comment


    • #3
      Re: Channel save problem

      Thanks for the reply, but what is the resolution for mirth1.1 ?

      (i.e. Do you need to change the password in mirth.properties?)

      Help

      Comment


      • #4
        Re: Channel save problem

        I did change the password for the hsqldb database in the mirth.properties file. Which caused a null pointer exception. So I also changed the database/mirth.script (Create User sa Password "nonblankpassword".

        However the result was the same pop up message: "There was a problem with one or more of your connectors. Please validate all of your connectors to find the problem."

        Any help would be appreciated on this problem.

        Thanks.

        Comment


        • #5
          Re: Channel save problem

          I dont know how relevant this is, but I find that when I get that error (quite often actually) I have to select my very last destination and click save changes. Don&#039;t know why it works, but it seems to fix the problem.

          Comment


          • #6
            Re: Channel save problem

            I was getting this issue with 1.4 - in order to get it to disappear I entered meaningless data in the template box of a filewriter in the destination tabe. I'm guessing the message pops-up when there is "something wrong with the connector" as it states, however a specific message detailing the missing required elements or even some sort of denotation that certain elements are required would be helpful.

            Comment


            • #7
              Re: Channel save problem

              Thanks for the suggestion - can you add that to the jira?
              Chris Lang

              Comment

              Working...
              X