No announcement yet.

How to run Mirth Shell on Appliance

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to run Mirth Shell on Appliance

    We have Mirth Connect on an pico appliance (appliance version: 3.1.13 ).

    We do not have any remote terminal access or console access to the appliance.

    How can I run Mirth Shell commands against this instance? The documentation says to use shell-launcher.jar shell-launcher.xml but since I do not have access to the appliance itself, I cannot find thse files.

    Note: I have the privileges to connect to the appliance dashboard and appliance control, start/stop channels, deploy channels, etc... through the web ui but I want to automate this so I need do it through the shell.

  • #2
    Console does not have java/shell either

    Also, I neglected to mention. I login through the console account onto the appliance but when I select command line from the menu, I do
    not have access to Java (comes up not found) and also can not find the shell-launcher.jar or shell-launcher.xml either.


    • #3
      Hello, download the Mirth Connect software to a Windows or Linux system of your choosing, and run the shell from there, connecting to your appliance over the network. There is an example (for Linux) and shell.bat (for Windows) included with Mirth Connect--copy it to a new file and change the IP address, username, and/or password as needed. For example your might look like:

      java -jar shell-launcher.jar shell-launcher.xml -a -u admin -p admin -v 0.0.0

      Where is the IP address of your appliance. If you're using Windows, modify the shell.bat file in the same way.

      If you have Silver support or better from the Mirth Corporation you can watch Developer Q&A webinar #9, where one of our developers discusses the Mirth Connect shell, demonstrating this and more (seek forward to 13 min 38 seconds).


      • #4
        Getting an error on the shell Luancher


        I unzipped the Mirth Connect package and tried running Mirth Shell. Unforunately when I do, I get the following error message:
        Exception in thread "main" java.lang.UnsupportedClassVersionError: com/webreach/mirth/server/launcher/ShellLauncher (Unsupported major.minor version 49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at n Source)
        at Source)
        at$100(Unknown Source)
        at$ Source)
        at Method)
        at Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)


        • #5
          Is the shell available on the PICO appliance?


          Also, if I ssh over to the Pico Appliance how come the Mirth Shell is not available on that machine?



          • #6
            Error message when using Mirth Shell.

            I upgraded my version of Java from 1.4 to 1.6 and I no longer get that version error.


            • #7
              Glad you got it working. Your are correct in that Mirth Connect does require Java 1.5+ with version 1.8.2 and below. Java 1.6 will be required starting with Mirth Connect 2.0.
              Jacob Brauer
              Director, Software Development
              NextGen Healthcare