Announcement

Collapse
No announcement yet.

Authenticate to Care360 web service

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Authenticate to Care360 web service

    Can anyone help me with authenticating to the Care360 (or any) web service? I'm trying to send a request to their results service which requires authentication. I've setup a SOAP Sender destination and I've been able to connect - but I get an error "(401)Authorization Required" response. Where/how do I authenticate? When I enter the request URL into a web browser, I am asked for autentication credentials - and get authenticated for the session - but that doesn't do me much good from within Mirth. Can anyone help?

    I found the following detailed part of the response error message received from Care360 in the log:

    The request requires user authentication. The response MUST include a WWW-Authenticate header field (section 14.46) containing a challenge applicable to the requested resource. The client MAY repeat the request with a suitable Authorization header field (section 14.8). If the request already included Authorization credentials, then the 401 response indicates that authorization has been refused for those credentials. If the 401 response contains the same challenge as the prior response, and the user agent has already attempted authentication at least once, then the user SHOULD be presented the entity that was given in the response, since that entity MAY include relevant diagnostic information. HTTP access authentication is explained in section 11.

  • #2
    Have you tried putting the username/password in the URL? You can generally do that as http://username[email protected]

    Another option would be to use the HTTP Sender and add the proper header variables.
    Jacob Brauer
    Director, Software Development
    NextGen Healthcare

    sigpic

    Comment


    • #3
      SOAP Sender to care360 (Quest)

      This does work well for this instance. Thank you!

      PaulC
      Originally posted by jacobb View Post
      Have you tried putting the username/password in the URL? You can generally do that as http://username[email protected]

      Another option would be to use the HTTP Sender and add the proper header variables.

      Comment

      Working...
      X