Announcement

Collapse
No announcement yet.

Send ACK error: StringIndexOutOfBoundsException

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Send ACK error: StringIndexOutOfBoundsException

    Hello,

    Mirth n00b here. I keep receiving the error below [Mirth Version 1.7.1.3422]. Anyone ever seen it or know what might be causing it? The File Writer connector works fine and the file is written fine, but when Mirth goes to write the ACK, I get the following. Thanks for the space,

    -----------------------------------------------------------------------------

    [2008-11-20 18:00:23,331] ERROR (org.mule.impl.DefaultComponentExceptionStrategy:9 5): Caught exception in Exception Strategy for: 75fbad2b-2987-4775-b407-23e769044092: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    at java.lang.String.substring(Unknown Source)
    at com.webreach.mirth.connectors.mllp.ACKGenerator.ge nerateAckResponse(ACKGenerator.java:42)
    at com.webreach.mirth.connectors.mllp.ACKGenerator.ge nerateAckResponse(ACKGenerator.java:16)
    at com.webreach.mirth.connectors.mllp.MllpMessageRece iver$TcpWorker.generateACK(MllpMessageReceiver.jav a:579)
    at com.webreach.mirth.connectors.mllp.MllpMessageRece iver$TcpWorker.processHL7Data(MllpMessageReceiver. java:478)
    at com.webreach.mirth.connectors.mllp.MllpMessageRece iver$TcpWorker.processData(MllpMessageReceiver.jav a:418)
    at com.webreach.mirth.connectors.mllp.MllpMessageRece iver$TcpWorker.preprocessData(MllpMessageReceiver. java:380)
    at com.webreach.mirth.connectors.mllp.MllpMessageRece iver$TcpWorker.run(MllpMessageReceiver.java:337)
    at org.mule.impl.work.WorkerContext.run(WorkerContext .java:290)
    at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor$Worker.runTask(ThreadPoolExecutor. java:650)
    at edu.emory.mathcs.backport.java.util.concurrent.Thr eadPoolExecutor$Worker.run(ThreadPoolExecutor.java :675)
    at java.lang.Thread.run(Unknown Source)

    -----------------------------------------------------------------------------

    Post edited by: smokydays, at: 11/20/2008 16:12

    Post edited by: smokydays, at: 11/20/2008 16:17

  • #2
    Re:Send ACK error: StringIndexOutOfBoundsException

    Could you explain the input/output of your channel ?

    Comment


    • #3
      Re:Send ACK error: StringIndexOutOfBoundsException

      I was getting the same error. I found that adding some text to the "ackMsgSuccessful" property of the source connector fixed the problem. I just typed "Good Message" in the configuration field and saved and restarted the channel. It worked after that.

      Comment


      • #4
        Re:Send ACK error: StringIndexOutOfBoundsException

        We are getting the same exact error in 1.7.1 and adding the text to successful message and redeploying the channel doesn't work for us.

        This doesn't happen in the previous version.
        Channel type: HL7V2x

        Any other suggestion?
        Thank you.

        Comment


        • #5
          please check your channel input edit filter or destination edit filter it might causing that error....remove those filters..if it is there!.......

          Comment

          Working...
          X