Announcement

Collapse
No announcement yet.

SQL 2008 Express. First test

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL 2008 Express. First test

    Hi all,

    I'm testing Mirth 1.8.0 RC3 with SQL 2008 Express. At this time I could say that it works with a little few changes on database configuration. Basically I found that SQL 2008 creates an instance for main database, at this point anyone can use this connection string on Mirth manager:

    jdbc:jtds:sqlserver://localhost:1433/mirthdb;instance=instance_name

    This works great same than in SQL 2005.

    First real trouble with Mirth comes when executing it first time, nothing works but you can simply avoid a lot of troubles configuring MIRTHDB with a compatibility level of 80 instead of 100 as SQL 2008 default. (Use this sequence to change that behaviour: SQL 2008 management studio -> right click on MIRTHDB database -> Properties -> Options -> Compatibility level, and change to SQL server 2000 (80)..... and everything goes right!

    I had to run database package in order to generate complete database and its tables and later, I found that preferences table was misspelled as PREFERNECES. Simply modifying table name, troubles with Plugin screen were solved.

    If anybody needs further assistance I could help you!.

    HTH,

    Ricard Bernat

  • #2
    Re:SQL 2008 Express. First test

    Hello!
    I'm trying to connect to SQL Server 2008 called SIAMMirthPrueba. The database is running on c1249 server and has windows authentication method in wich my domain user and password are respectively "hacandelo" and "20304050".

    At this moment I'm using the following URL to connect
    dbc: jtds : sqlserver: //c1249:1433/SIAMPruebaMirth
    but It doesn't work
    Wha Can I do?? I supposed this coul be a driver problem How I can resolve this?

    Comment


    • #3
      Re:SQL 2008 Express. First test

      Hello!
      I'm trying to connect to SQL Server 2008 called SIAMMirthPrueba. The database is running on c1249 server and has windows authentication method in wich my domain user and password are respectively "hacandelo" and "20304050".

      At this moment I'm using the following URL to connect
      dbc: jtds : sqlserver: //c1249:1433/SIAMPruebaMirth
      but It doesn't work
      Wha Can I do?? I supposed this coul be a driver problem How I can resolve this?

      Comment


      • #4
        Re:SQL 2008 Express. First test

        Hi hcandelo,

        one question did you configured SQL 2008 in order to receive TCP/IP connections throught SQL server configuration tool?.

        If the answer is yes then second step is: can you change SQL server security to mixed and try to connect as user sa?.

        If last option doesn't work, can you check if there is an instance running on SQL server?.

        Surely you will resolve the issue answering first question.

        HTH,

        Ricard Bernat

        Comment


        • #5
          Re:SQL 2008 Express. First test

          Hi,
          I've reviewed all the things you put here. One thing important to say is that my BD is not SQL Express.

          When conect to BD using Microsoft SQL Server Management Studio
          Server type: Database Engine
          Server Name: c1249\sql2008
          Autentication: Windows Atentication


          Adicionally, I downloaded the driver for SQL Server in MSD then I added a row in the xml file to register components and I put the driver in the configuration directory.

          Now I don't know what happens
          If you can give a hand, welcome....
          Thanks a lot.

          Comment


          • #6
            Re:SQL 2008 Express. First test

            Hi hcandelo,

            first, if your database is SQL server 2008, surely you never could connect from Mirth. Change to mixed mode (SQL/Windows) and then mirth could log to SQL with a SQL user,not windows user.

            There is no need to download any driver from MS.

            HTH,

            Ricard Bernat

            Comment


            • #7
              feiled ton connect to sql 2008

              had the same problem the solution is to use the ODBC driver on Windows machine, make a connection to the database and use this URL for communication. jdbcdbc:"connection name in ODBC" items. if your connection is called SQLTOMIRTH then the URL will looks like this jdbcdbc:SqlToMirth
              Last edited by kheder; 07-25-2012, 03:53 AM.

              Comment

              Working...
              X