Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Installing on Redhat Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installing on Redhat Linux

    I am trying to install Mirth 1.8.0 RC on a Linux box (Linux 2.6.9-67.0.22.EL) running Plesk (version 8.4). Plesk is an appliance that uses port 8443. Is that a problem?

    I am trying to run from the console using "java -jar shell-launcher.jar shell-launcher.xml -a https://127.0.0.1:8443 -u admin -p admin -v 0.0.0" which gives a "HTTP/1.1 404 Not Found" error. If I change the port to 8484 in the mirth.properties file, then I get a "Connection refused" error.

    Can someone get me on the yellow brick road? I've also tried Mirth 1.7.1 with similar frustrations.

    TIA,
    N.

  • #2
    Re:Installing on Redhat Linux

    What you have to run is the server, using the daemon or mirth.sh

    the shell is a way for accessing to the server

    Comment


    • #3
      Re:Installing on Redhat Linux

      Thanks. Been down that path as well.

      [[email protected] Mirth]# ./mirth.sh
      ERROR 2008-10-16 21:28:33,622 [main] com.webreach.mirth.server.controllers.DefaultExten sionController: could not initialize extension settings
      com.thoughtworks.xstream.converters.ConversionExce ption: library : library
      ...

      Then when I try to access using the Mirth Administrator it fires up Jave Web Start to start the Admin, but says "Unable to launch the application."

      Comment


      • #4
        Re:Installing on Redhat Linux

        nhweid wrote:
        I've also tried Mirth 1.7.1 with similar frustrations.
        Lets stick with 1.7.1 for now. That will ensure that we're chasing issues on your installation and not bugs in the RC.

        The rough installation process is outlined here: http://www.mirthproject.org/index.ph...0&catid=2#6620

        Double check that and post back.
        Jon Bartels

        Zen is hiring!!!!
        http://consultzen.com/careers/
        Talented healthcare IT professionals wanted. Engineers to sales to management.
        Good benefits, great working environment, genuinely interesting work.

        Comment


        • #5
          Re:Installing on Redhat Linux

          Thanks, Jon. Back to 1.7.1. Finished the install. Ran ./mirth.sh with following results:

          [[email protected] Mirth]# ./mirth.sh
          WARN 2008-10-17 11:05:43,322 [Thread-0] org.mortbay.util.ThreadedServer: Failed to start: [email protected]:8080
          WARN 2008-10-17 11:05:43,323 [Thread-0] com.webreach.mirth.server.Mirth: Could not start web server.
          org.mortbay.util.MultiException[java.net.BindException: Address already in use]
          at org.mortbay.http.HttpServer.doStart(HttpServer.jav a:686)
          at org.mortbay.util.Container.start(Container.java:72 )
          at com.webreach.mirth.server.Mirth.startWebServer(Mir th.java:397)
          at com.webreach.mirth.server.Mirth.startup(Mirth.java :148)
          at com.webreach.mirth.server.Mirth.run(Mirth.java:113 )
          java.net.BindException: Address already in use
          at java.net.PlainSocketImpl.socketBind(Native Method)
          at java.net.PlainSocketImpl.bind(Unknown Source)
          at java.net.ServerSocket.bind(Unknown Source)
          at java.net.ServerSocket.<init>(Unknown Source)
          at org.mortbay.util.ThreadedServer.newServerSocket(Th readedServer.java:391)
          at org.mortbay.util.ThreadedServer.open(ThreadedServe r.java:477)
          at org.mortbay.util.ThreadedServer.start(ThreadedServ er.java:503)
          at org.mortbay.http.SocketListener.start(SocketListen er.java:203)
          at org.mortbay.http.HttpServer.doStart(HttpServer.jav a:716)
          at org.mortbay.util.Container.start(Container.java:72 )
          at com.webreach.mirth.server.Mirth.startWebServer(Mir th.java:397)
          at com.webreach.mirth.server.Mirth.startup(Mirth.java :148)
          at com.webreach.mirth.server.Mirth.run(Mirth.java:113 )
          Mirth 1.7.1.3422 (April 23, 2008) server successfully started: Fri Oct 17 11:05:48 EDT 2008
          This product includes software developed by SymphonySoft Limited (http://www.symphonysoft.com) and its contributors.
          Running Java 1.6.0_07 on Linux (2.6.9-67.0.22.EL, i386)

          Then got the big green button from the browser and started the Administrator. After dismissing the messages, tried the login with admin/admin and got the following error:



          "There was a problem authenticating the information that was entered. Please verify that the server is up and running and that the user information is valid."

          Comment


          • #6
            Re:Installing on Redhat Linux

            Code:
            [[email protected] Mirth]# ./mirth.sh
            WARN  2008-10-17 11:05:43,322 [Thread-0] org.mortbay.util.ThreadedServer: Failed to start: [email protected]:8080
            WARN  2008-10-17 11:05:43,323 [Thread-0] com.webreach.mirth.server.Mirth: Could not start web server.
            Now we've got something to go on.

            Before you start mirth run:

            Code:
            sudo netstat -pant | grep 8443
            sudo netstat -pant | grep 8080
            If you get nothing then the ports that Mirth uses by default are available, if you get something then have a look and see what process is using it. If its java it may be a stale Mirth process, if its anything else you'll need to change Mirths ports.

            Mirth gets its port numbers from the conf/mirth.properties file, tweak that to use an available port. Don't forget to check the firewall rules as well.

            You'll also need to adjust the connection string once the client comes up, just change the port.
            Jon Bartels

            Zen is hiring!!!!
            http://consultzen.com/careers/
            Talented healthcare IT professionals wanted. Engineers to sales to management.
            Good benefits, great working environment, genuinely interesting work.

            Comment


            • #7
              Re:Installing on Redhat Linux

              Here's what netstat told me:

              [[email protected] ~]# sudo netstat -pant | grep 8443
              tcp 0 0 0.0.0.0:8443 0.0.0.0:* LISTEN 3349/httpsd
              [[email protected] ~]# sudo netstat -pant | grep 8080
              tcp 0 0 :::8080 :::* LISTEN 10974/java

              So I changed the port to 8444 in mirth.properties.

              Then I still got errors:

              [[email protected] Mirth]# ./mirth.sh
              WARN 2008-10-17 13:34:20,793 [Thread-0] org.mortbay.util.ThreadedServer: Failed to start: [email protected]:8080
              WARN 2008-10-17 13:34:20,794 [Thread-0] com.webreach.mirth.server.Mirth: Could not start web server.

              So I killed the java process listenting on 8080 and reran the shell giving different errors:

              [[email protected] Mirth]# sudo netstat -pant | grep 8080
              tcp 0 0 :::8080 :::* LISTEN 10974/java

              [[email protected] Mirth]# kill -9 10974

              [[email protected] Mirth]# sudo netstat -pant | grep 8080

              [[email protected] Mirth]# ./mirth.sh
              ERROR 2008-10-17 13:44:02,527 [Thread-0] com.webreach.mirth.server.controllers.MessageObjec tController: java.sql.SQLException: Failed to start database '/opt/Mirth/mirthdb', see the next exception for details.
              ERROR 2008-10-17 13:44:02,537 [Thread-0] com.webreach.mirth.server.controllers.SystemLogger : java.sql.SQLException: Failed to start database '/opt/Mirth/mirthdb', see the next exception for details.
              ERROR 2008-10-17 13:44:02,548 [Thread-0] com.webreach.mirth.server.controllers.ChannelStati sticsController: Could not initialize channel statistics.
              ERROR 2008-10-17 13:44:02,562 [Thread-0] com.webreach.mirth.server.controllers.Configuratio nController: could not initialize configuration settings
              ...
              Mirth 1.7.1.3422 (April 23, 2008) server successfully started: Fri Oct 17 13:44:02 EDT 2008
              This product includes software developed by SymphonySoft Limited (http://www.symphonysoft.com) and its contributors.
              Running Java 1.6.0_07 on Linux (2.6.9-67.0.22.EL, i386)

              But then I could not access the Administrator using 8080.

              Comment


              • #8
                Re:Installing on Redhat Linux

                Try this general Linux install process:

                Download Mirth 1.7.1
                Copy to directory /opt/mirth1.7.1
                A directory will be created ? mirth-1.7.1

                cd /opt.mirth1.7.1/mirth-1.7.1

                Change Mirth port to 8090: conf/mirth.properties file

                Change execute permissions:
                Chmod +x

                Open Firefox browser

                Start Mirth
                http://localhost:8090

                Click the button to launch the Mirth Administrator
                You will be asked to download the java file ? webstart.jnlp
                (Place this file in the javaws directory - /usr/local/jdk1.5.0_04/jre/javaws/javaws)
                ** Or whatever your java jdk directory is

                Mirth Administrator:
                Listening on ? https://localhost:8443

                Username: admin
                Password: admin

                Launch Mirth Server
                cd /opt/mirth1.7.1/mirth-1.7.1
                ./mirth-daemon start

                Comment


                • #9
                  Re:Installing on Redhat Linux

                  Thanks, Ed.

                  I finally got this running by changing both 8080 and 8443 in mirth.properties to unused ports on my server.

                  I did not have to Chmod +x (not sure which files anyway).

                  Now I just have to figure out how to make sure the Mirth daemon stays running.

                  And when I get to using Mirth, I'm sure I'll have more questions. Thanks again for the quick help.

                  N.

                  Comment


                  • #10
                    Re:Installing on Redhat Linux

                    nhweid wrote:
                    Now I just have to figure out how to make sure the Mirth daemon stays running.
                    Copy the mirth-daemon script to /etc/init.d (or its RH equivalent) and add it to your rc.X's to run at boot (`update-rc.d mirth-daemon defaults` in Debian/Ubuntu, `chkconfig` - in RedHat IIRC)

                    Post edited by: jbartels, at: 10/19/2008 07:25
                    Jon Bartels

                    Zen is hiring!!!!
                    http://consultzen.com/careers/
                    Talented healthcare IT professionals wanted. Engineers to sales to management.
                    Good benefits, great working environment, genuinely interesting work.

                    Comment

                    Working...
                    X