Announcement

Collapse
No announcement yet.

Problems with the namespace of an HL7 XML

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with the namespace of an HL7 XML

    Hi experts,
    I am trying to use mirth to send an HL7 XML to the MESA tool. That HL7 XML has the following format and namespace prefix: <ns0:MSH.1>|</MSH.1>.... Unfortunately, the mirth tool returns me an transformation error and I am convinced that this ist due to that prefix. If I remove it, everthing is working properly. Do you have an idea how I can configure the tool so that it ignores the prefixes

    Thank you in advance.
    Best Regards, Doris

    Post edited by: Doris, at: 10/16/2008 08:51

  • #2
    Re:Problems with the namespace of an HL7 XML

    Doris,

    I can't offer specific advice, but I do recall a few threads in recent months where others had issues with XML namespaces. I think a quick search might be in order.

    Post back if nothing comes up and we can dig into it more.
    Jon Bartels

    Zen is hiring!!!!
    http://consultzen.com/careers/
    Talented healthcare IT professionals wanted. Engineers to sales to management.
    Good benefits, great working environment, genuinely interesting work.

    Comment


    • #3
      Re:Problems with the namespace of an HL7 XML

      perhaps a replaceAll("<ns0:","<") in the preprocessor?

      Comment


      • #4
        Re:Problems with the namespace of an HL7 XML

        This should work. If you could post your channel, error, and a sample message that would be useful.

        Post edited by: jacobb, at: 10/17/2008 11:07
        Jacob Brauer
        Director, Software Development
        NextGen Healthcare

        sigpic

        Comment


        • #5
          Re:Problems with the namespace of an HL7 XML

          This is a known problem related to HAPI. Namespace aren't understand well. Try using Qumicefa solution

          Comment


          • #6
            Re:Problems with the namespace of an HL7 XML

            Hi,
            Thank you for your hint. Replace statement is working fine. Unfortunately, I also have the problem with the direction the other way round. Meaning, our system requires a namespace and I am not able to add it. Here, no replacement is working.

            Does anyone have an idea for me?
            Thank you in advance.

            Best Regards, Doris

            Comment


            • #7
              Re:Problems with the namespace of an HL7 XML

              Maybe you can use XSLt to strip off the namespaces before processing the message in Mirth, and in the postprocessor, another XSLt to add the required namespaces for you system.

              ?

              Comment


              • #8
                Re:Problems with the namespace of an HL7 XML

                Hi colleagues,

                thank you all for your support. My scenario is running fine now (at least today..). I have the impression that namespace problems are disturbing that much that I separated the steps. Meaning: strip the namespace, save the new structure to file, read it with a file reader and do the mapping in that step.

                Best Regards, Doris

                Comment


                • #9
                  Re:Problems with Pre-Processor

                  Hi All,

                  I am new to Mirth Tool, Can anyone tell me how to use preprocessor in this tool


                  Thanks In Advance.

                  Comment

                  Working...
                  X