Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

LLP Sender: data delivered but connection refused

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • LLP Sender: data delivered but connection refused

    Hello all,

    I have a channel that sends data trough LLP Protocol. The endpoint gets the data correctly but the strange thing about it is - with every sent HL7-message I get a WARNING that the connection to the endpoint has been refused. Do you know where the WARNING come from?
    Here is my log

    [2008-10-02 12:08:23,196] INFO (postprocessor:?): AL1: Sent mesage and set statusCodeHL7=301 for protocol number: 5673
    [2008-10-02 12:08:24,227] WARN (com.webreach.mirth.connectors.mllp.MllpMessageDis patcher:199): Can't connect to the endopint,waiting10.0seconds for reconnecting
    (java.net.ConnectException: Connection refused: connect)
    I've attached my channel on this post.

    Thank you,



    DB_SENDERTASK_MAIN_2008_09_28.xml (13244 bytes)

  • #2
    Re:LLP Sender: data delivered but connection refused

    I was having this same problem. I changed the port numbers on the receiving end and on the destinatin channel and this resolved the problem. There was no reason why the current port shouldn't have worked. My guess is, the incoming port on the receiving end must have been in use by some process that I couldn't detect.

    - Marty

    Comment


    • #3
      Re:LLP Sender: data delivered but connection refused

      Thank you!

      You had right! The channels tries to open a connection that has already been opened. That's why I get the message "connection refused". "Keep connection open" solved the problem.

      Greets,

      Svetlomir

      Post edited by: Svetlomir Kasabov, at: 10/10/2008 08:52

      Comment

      Working...
      X