Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Cannot login as admin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot login as admin

    Hi,
    I am new to Mirth. I just installed it using the wizard. I had no error during the install. Then I started the server and it starts ok except for one warning:

    WARN 2008-09-03 17:39:49,019 [Thread-0] com.webreach.mirth.server.Mirth: Error deploying channels.
    org.mozilla.javascript.EcmaError: ReferenceError: "XML" is not defined. (c6f04ce1-6dc5-439e-b59e-77e81468fab6#4)
    at org.mozilla.javascript.ScriptRuntime.constructErro r(ScriptRuntime.java:3350)
    at org.mozilla.javascript.ScriptRuntime.constructErro r(ScriptRuntime.java:3340)
    at org.mozilla.javascript.ScriptRuntime.notFoundError (ScriptRuntime.java:3413)
    at org.mozilla.javascript.ScriptRuntime.name(ScriptRu ntime.java:1612)
    at org.mozilla.javascript.gen.c1._c0(c6f04ce1-6dc5-439e-b59e-77e81468fab6:4)
    at org.mozilla.javascript.gen.c1.call(c6f04ce1-6dc5-439e-b59e-77e81468fab6)
    at org.mozilla.javascript.ContextFactory.doTopCall(Co ntextFactory.java:393)
    at org.mozilla.javascript.ScriptRuntime.doTopCall(Scr iptRuntime.java:2834)
    at org.mozilla.javascript.gen.c1.call(c6f04ce1-6dc5-439e-b59e-77e81468fab6)
    at org.mozilla.javascript.gen.c1.exec(c6f04ce1-6dc5-439e-b59e-77e81468fab6)
    at com.webreach.mirth.server.util.JavaScriptUtil.ente rContext(JavaScriptUtil.java:74)
    at com.webreach.mirth.server.util.JavaScriptUtil.comp ileAndAddScript(JavaScriptUtil.java:161)
    at com.webreach.mirth.server.controllers.Configuratio nController.compileScripts(ConfigurationController .java:320)
    at com.webreach.mirth.server.Mirth.startMule(Mirth.ja va:231)
    at com.webreach.mirth.server.Mirth.startup(Mirth.java :163)
    at com.webreach.mirth.server.Mirth.run(Mirth.java:113 )


    I managed to connect to the server using the text console and issued a few commands. It looks ok. But when i tried to login through the webstart application I got stuck on the login part. It refuses to log me in as admin/admin.

    I tried uninstalling and installing as root but it's still the same. I am using Ubuntu Hardy 64 as desktop and java 1.6.0. I have checked your forum for possible solutions but none worked. Do you have any ideas on what went wrong on my install?

    Thank you.

  • #2
    Re:Cannot login as admin

    You should use java 5 and not 6. I had the same issue on ubuntu too, but I changed the java version and it worked fine.

    Comment

    Working...
    X