Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Mirth Administrator - window resize problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth Administrator - window resize problem

    This might be a Mirth bug, might not...

    I recently put Ubuntu 8.02 on my main workstation, replacing Fedora Core 6. (This is not the machine Mirth is running on.) When I start up Mirth Administrator, it comes up in the default size window. When I maximize the window, the window goes full-screen, but the area taken up by Mirth Administrator does not change. Same result if I grab a corner and resize the window - the additional space in the window is just a bunch of gray.

    This worked correctly on FC6 running JDK1.5.0_04. Ubuntu has JRE1.5.0_15-b04 on it. I may try an older version of Java and see if anything changes...

    Any suggestions?

    Mike

  • #2
    Re:Mirth Administrator - window resize problem

    This does not happen for us on the same environment. Could you double check to make sure you are using the Sun version of Java?
    Jacob Brauer
    Director, Software Development
    NextGen Healthcare

    sigpic

    Comment


    • #3
      Re:Mirth Administrator - window resize problem

      Verified it's Sun Java (installed via synaptic). Also tried Sun JDK 1.5.0_11 with the same result.

      My laptop is also acting the same way... I'll try removing anything Java-related that synaptic installed and see if that points me anywhere.

      Comment


      • #4
        Re:Mirth Administrator - window resize problem

        Well this is interesting... On my laptop, I turned off visual effects under System->Preferences->Appearance, launched Mirth Administrator, and it behaved correctly. Setting visual effects back to "Normal" then launching MA made it goof up again.

        Here's the weird part: Turn off effects, launch MA, turn effects back on - MA still behaves correctly with effects on (maximize, resize, etc). It seems that the bad behavior is determined by the effects setting when MA is started, not how it's set when you adjust the window size.

        I'll try this on my workstation later tonight and see if it does the same thing.

        Comment


        • #5
          Re:Mirth Administrator - window resize problem

          Confirmed on my workstation.

          This is a goofy problem... Any thoughts about what might be causing it? In particular, why the setting at the time MA is started makes the difference? At least there's a workaround.

          Thanks, Mike

          Comment


          • #6
            Re:Mirth Administrator - window resize problem

            Can you also confirm that you're using Sun Java by running
            Code:
            update-alternatives --config java
            Jon Bartels

            Zen is hiring!!!!
            http://consultzen.com/careers/
            Talented healthcare IT professionals wanted. Engineers to sales to management.
            Good benefits, great working environment, genuinely interesting work.

            Comment


            • #7
              Re:Mirth Administrator - window resize problem

              [email protected]:/home/mike# update-alternatives --config java

              There is only 1 program which provides java
              (/usr/lib/jvm/java-1.5.0-sun/jre/bin/java). Nothing to configure.
              [email protected]:/home/mike# ls /usr/lib/jvm
              java-1.5.0-sun java-1.5.0-sun-1.5.0.15
              [email protected]:/home/mike#

              Comment


              • #8
                Gave up on this issue for a long time, finally came back to it. Posting a response just for historical purposes...

                Turns out using the JavaWS included in Sun Java 1.6.0-14 appears to fix this problem. Only have done some quick tests, but the Admin GUI appears to finally handles window resize events correctly. I'll run it under this configuration next week when doing "real" work with the GUI and post any problems I find.

                Comment

                Working...
                X