Mirth Connect 4.0.1 Released!

Mirth Connect 4.0.1 is now available as an appliance update and on our GitHub page. Mirth Connect 4.0.1 is a patch release containing a bug fix which includes fixing a Jetty keystore regression that caused Connect servers using a PKCS12 keystore containing a wildcard certificate and/or a certificate with a SAN to throw an exception on startup. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Channel won't start

  • Filter
  • Time
  • Show
Clear All
new posts

  • Channel won't start

    Attached is the channel in question: a simple LLP listener with a HTTP sender. It's the only enabled channel.

    However, when deploying and/or when trying to start the channel, it stays stopped and gives this error:

    org.mule.providers.FatalConnectException: ReconnectStrategy "org.mule.providers.SingleAttemptConnectionStrategy" failed to reconnect receiver on endpoint "mllp://"
    The exact same configuration works fine on my laptop (osx), but not on the server (debian). Port in question (6661) is not open, so it should be able to open the port and start listening. Also, I've tried other ports and other types of listeners, none work.

    Anyone experience this before?

    Post edited by: marten, at: 08/18/2008 04:47

  • #2
    Re:Channel won't start

    This may sound strange but ... have you the "lo" interface correctly configured and running?

    I Have seen some X-files on Linux with boxes that have a misconfigured localhost interface.


    • #3
      Re:Channel won't start

      Yes, lo does exist and works.


      • #4
        Re:Channel won't start

        We're running Mirth on a Windows box for the time being, but just tried it with Mirth 1.8, and the problem still persists.

        [2009-02-04 11:05:07,279] ERROR (org.mule.impl.model.seda.SedaModel:377): Error starting component [7b12b61b-7949-4923-a862-1e7e1975efcb]
        org.mule.providers.FatalConnectException: ReconnectStrategy "org.mule.providers.SingleAttemptConnectionStrateg y" failed to reconnect receiver on endpoint "mllp://"

        I would really like any ideas, I'm at a loss to what this could be.


        • #5
          Re:Channel won't start

          There are other exceptions in the wrapper.log file ? Is the 6661 port free or it's being used by other program/service?


          • #6
            Re:Channel won't start

            quimicefa wrote:
            There are other exceptions in the wrapper.log file ? Is the 6661 port free or it's being used by other program/service?
            No, nothing else in wrapper.log (other than JVM startup and shutdown info messages), and the port isn't in use yet. Fresh debian etch install, fresh mirth install.


            • #7
              Re:Channel won't start

              Then, raise the log level to DEBUG ( and try to get more info just before the ERROR happens (and post it here)

              edit: Test using "" as binding address in the MLLP Listener, instead of or the real NIC address!

              BTW: which user is running Mirth, root?

              Hope that helps!

              Post edited by: quimicefa, at: 02/04/2009 04:08