Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

File Writer: "Content not allowed in prolog" error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • File Writer: "Content not allowed in prolog" error

    Trying to do a simple Database Reader, transform to HL7 and write the HL7 out to a file. The transformation appears to go well but the File Writer Destination errors out with "org.xml.sax.SAXParseException: Content is not allowed in prolog." In the Dashboard message for the Destination the "Raw Message" has the transformed HL7 but it seems like the channel is trying to read it as XML. Any help? Channel Attached.

    Thanks! DLS_Patient_Registry.xml (6391 bytes)

  • #2
    Re:File Writer: "Content not allowed in prolog" error

    your outbound message protocol in the destination is set to XML, not HL7. Change that to HL7, and then I think it'll work.
    Chris Ro
    Sr. Software Engineer | Mirth Corporation

    Comment


    • #3
      Re:File Writer: "Content not allowed in prolog" er

      I've ran into a similar problem when I defined a channel with XML protocol, saved, and then changed to HL7 and saved. Note that AFAIK, SAX is a java library to parse XML, not HL7.

      The workarround in my scenario was defining the whole channel from scratch. It seems like a bug, because only the first UMO changes the protocol to HL7, but the rest of them (destination, filters, ...) apparently not.

      Comment


      • #4
        Re:File Writer: "Content not allowed in prolog" error

        Where do I change the outbound message protocol? I don't see that open in the Destination editor. Thanks for your help!

        Comment


        • #5
          Re:File Writer: "Content not allowed in prolog" error

          Go to the Destination tab -> Edit Transformer -> Message Templates tab.

          You'll see Inbound/Outbound message templates along with the Data Type option. Change the outbound data type to HL7.
          Chris Ro
          Sr. Software Engineer | Mirth Corporation

          Comment

          Working...
          X