Announcement

Collapse
No announcement yet.

Need help with channel for HL7 v2 via HTTP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with channel for HL7 v2 via HTTP

    I created a channel that receives an HL7 message via HTTP and saves the message to disk. I am testing this using HAPI Test Panel. Every time I send I get a timeout error, and the channel is not returning my ACK. I've attached the channel, can I get a little help? This is on Mirth 3.6.2
    Attached Files
    Last edited by wheresjim; 11-25-2019, 01:24 PM.

  • #2
    I don't use HAPI Test Panel but it looks like that uses MLLP, not HTTP. If you are using HTTP, maybe try Postman?

    -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
    -= [email protected]
    -= Mirth Connect (Advanced)-certified
    -= Gold member of HL7.org
    -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

    Comment


    • #3
      It supports both MLLP and HTTP, actually

      Comment


      • #4
        I see, sorry! You're using 8080 for your channel, which is used by Mirth by default. The channel (or Mirth) should use something different (can't reuse ports like that). Try changing the channel port to 45001 and try again? Works great for me if you change the port...

        -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
        -= [email protected]
        -= Mirth Connect (Advanced)-certified
        -= Gold member of HL7.org
        -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

        Comment


        • #5
          Due to firewall restrictions I set the Mirth non-encrypted server to listen to 8081, and Mirth to listen to 8080. I should have pointed that out, good catch, BTW!

          Comment


          • #6
            Just so someone coming behind understands... Mirth uses 8080 (HTTP) and 8443 (HTTPS) by default, although it is customizable. You can't create channels to listen on those ports (or any other ports that are in use by the server) and if you try, the channel SHOULDN'T start. wheresjim, so that I'm clear, the in-use port number was the problem?

            -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
            -= [email protected]
            -= Mirth Connect (Advanced)-certified
            -= Gold member of HL7.org
            -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

            Comment


            • #7
              Oh, no. Still not getting a response. I'm trying to send back the standard HL7 v2 ack in the response, but it's giving an indicating that the file was save correctly (Destination is a File Writer).

              I had accounted for the port issue when we figured out we could only receive data on certain ports because of the firewall restrictions.

              I have been trying the following in the response transformer for the File Writer destination:

              Code:
              var myack = new ACKGenerator();
              var ackHL7 = myack.generateAckResponse(response,true,"AA","Solved","yyyyMMddHHmmss","Error Occurred" );
              responseMap.put("customResponse",ResponseFactory.getSuccessResponse(ackHL7));
              
              return;
              I have customResponse selected in the source for a response, but it still just sends the "SENT: File successfully written: /Users/XXXXXXX/Desktop/landing/8221e012-e44c-4fc7-ab6c-b91df97abeb2.hl7" as a response.

              Comment


              • #8
                When I run it using Postman, I get:

                Code:
                MSH|^~\&|MIRTH|CLB||DEMO|20191125164741.201||ACK^O01^ACK|20191125164741.201|P|2.5.1
                MSA|AA|1

                -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
                -= [email protected]
                -= Mirth Connect (Advanced)-certified
                -= Gold member of HL7.org
                -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

                Comment


                • #9
                  Hmm, OK. I tried postman and I get a blank response. Are you setting the message in raw or in the form post?

                  It's nice to know this channel works somewhere, BTW!

                  Ahh, I hadn't set the MIME type correctly. Thanks! Working all the time!

                  Comment


                  • #10
                    I'm sending a POST, RAW, "text", using a sample HL7 message. The response in the source is the default "auto-generate (destinations completed)"

                    -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
                    -= [email protected]
                    -= Mirth Connect (Advanced)-certified
                    -= Gold member of HL7.org
                    -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

                    Comment


                    • #11
                      Thanks, It's now working perfectly for me with Postman. I'm going to ditch HAPI Test Panel. Thanks for your help!

                      Comment


                      • #12
                        Sorry to the HAPI Test Panel users, but Postman rocks!

                        -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
                        -= [email protected]
                        -= Mirth Connect (Advanced)-certified
                        -= Gold member of HL7.org
                        -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

                        Comment


                        • #13
                          I think the issue was not that you were using HAPI Test Panel, but that you were selecting a File Writer destination as your response instead of letting it auto generate an HL7 response for you.

                          Comment

                          Working...
                          X