Announcement

Collapse
No announcement yet.

Mirth setup in ubuntu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth setup in ubuntu

    Installing mirth and postgres configuration i done below steps.

    1. setup ubuntu server version 16.
    2. Downloaded and extracted file mirthconnect-3.4.2.8129.b167-unix.tar.gz to /opt.
    3. Postgres installed
    4. Setup database connection in mirth.properties.
    5. I run mcservice start

    Mirth came up. But the tables created in schema postgres. The i added "?currentschema=mirh" to the database url.
    Then i dropped and created database.

    Now i am facing issue to login and after removing and adding the folder to /opt directory mirth is staring and its not opening the first user registration screen.

    How to reinstall mirth from server and i need to start the service again

  • #2
    Unless I'm misunderstanding, you should be able to stop Mirth, drop the database, create the database (no tables), be sure the database name is correct in mirth.properties, then start Mirth. It will create everything you need, and your login will be admin/admin again.

    -= Jack Haines : Founder/CEO of Healthcare Integrations, LLC
    -= [email protected]
    -= Mirth Connect (Advanced)-certified
    -= Gold member of HL7.org
    -= Available for Mirth Connect channel development and consultation! Schedule a FREE call with me at https://calendly.com/jackhaines

    Comment


    • #3
      I think the terms database and schema are being mixed. From postgres wiki:

      A PostgreSQL database cluster contains one or more named databases. ... A database contains one or more named schemas, which in turn contain tables. Schemas also contain other kinds of named objects, including data types, functions, and operators.

      I think what you actually want to do is create a database manually via your postgres admin tool and call it "mirthdb". Create a user and grant that user db owner permissions on that database.

      Then in mirth.properites:
      Code:
      database = postgres
      database.url = jdbc:postgresql://<hostname or IP of db server>:5432/mirthdb
      
      database.username = <whatever username you created>
      database.password = <whatever database you created>
      And you aren't doing it already have the mirth process run as a named user other than root.
      Mirth 3.8.0 / PostgreSQL 11 / Ubuntu 18.04
      Diridium Technologies, Inc.
      https://diridium.com

      Comment


      • #4
        install postgres,
        Code:
        		apt-get install postgresql postgresql-contrib
        		update-rc.d postgresql enable
        		service postgresql start
        		su - postgres
        		psql
        		\q
        create db:
        Code:
        		createdb mirthdb
        		psql
        create role:
        Code:
        CREATE ROLE mirthdb LOGIN
        ENCRYPTED PASSWORD 'md5ffedeac0808a4430dd3bfa01f1d02bac'
        SUPERUSER INHERIT CREATEDB CREATEROLE REPLICATION;
        \q
        exit
        edit conf/mirth.properties to point to postgres:
        Code:
        database.url = jdbc:postgresql://localhost:5432/mirthdb
        database = postgres
        database.username = mirthdb
        database.password = mirthdb

        Comment


        • #5
          I'd restrict those permissions down a bit on the mirth database user of course. But what was posted will work.

          I would create the mirthdb user first then create the database setting the owner to be mirthdb
          Mirth 3.8.0 / PostgreSQL 11 / Ubuntu 18.04
          Diridium Technologies, Inc.
          https://diridium.com

          Comment

          Working...
          X