Announcement

Collapse
No announcement yet.

Updated to Mirth Connect 3.8.1 with Java 1.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updated to Mirth Connect 3.8.1 with Java 1.8

    I have searched through the forum but have not found this specific problem reported. I'm hoping someone has encountered this and has an answer or some suggestions.

    When launching the administrator 1.1.10 the log in is accepted but when it gets to "loading extensions" it gives an error "cannot launch administrator, please check that the mirth server is up and running"

  • #2
    Sounds like you are having a very similar issue that I am having. Really wish there was some sort of FAQ to deal with these sort of issues. Have you looked in the logs? See any errors?

    Comment


    • #3
      no errors in the mirth.log but when i leave the java console window it throws a Null Pointer exception. I will get the exact error and screenshots.

      Comment


      • #4
        here is a screenshot of our setup and the error:
        Attached Files

        Comment


        • #5
          The Mirth Connect service is probably running but no endpoint is created to the 8443 port.

          You can check by doing this:

          Start / run / cmd
          netstat -anp tcp | findstr "8443"

          If a return of "Listening" is listed then it is running but I'm suspecting it's not.

          The only way that I was really able to get around this somewhat generic error is to either rerun the Mirth update or reinstall your JRE version.

          Comment


          • #6
            It looks like it is listening. Dang
            Attached Files

            Comment


            • #7
              Originally posted by maharney View Post
              It looks like it is listening. Dang
              since you are running in windows, please check your firewall...

              Comment


              • #8
                [2019/11/13 19:43:16.441] GetLatestJavaws32or64Home():
                [2019/11/13 19:43:16.441] GetLatestJavawsVersion():
                [2019/11/13 19:43:16.441] checking 32-bit
                [2019/11/13 19:43:16.441] failed to open SOFTWARE\JavaSoft\Java Web Start
                [2019/11/13 19:43:16.441] GetLatestJavawsVersion():
                [2019/11/13 19:43:16.441] checking 64-bit
                [2019/11/13 19:43:16.441] Processing key: 1.0.1
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 1.0.1_02
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 1.0.1_03
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 1.0.1_04
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 1.2
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 1.2.0_01
                [2019/11/13 19:43:16.441] check JRE registry to see if it's an corrupted webstart key
                [2019/11/13 19:43:16.441] failed to recover webstart key when attempt to open jre key FAIL, error code[2]
                [2019/11/13 19:43:16.441] Processing key: 11.121.2
                [2019/11/13 19:43:16.441] latestVersion: 11.121.2 latestHome: C:\Program Files\Java\jre1.8.0_121\bin
                [2019/11/13 19:45:29.427] Latest deploy version:
                [2019/11/13 19:45:29.427] 11.121.2
                [2019/11/13 19:45:37.508] Latest deploy version:
                [2019/11/13 19:45:37.508] 11.121.2
                [2019/11/13 19:45:45.979] Latest deploy version:
                [2019/11/13 19:45:45.979] 11.121.2
                [2019/11/13 19:45:49.305] Latest deploy version:
                [2019/11/13 19:45:49.305] 11.121.2
                [2019/11/13 19:45:58.806] Latest deploy version:
                [2019/11/13 19:45:58.806] 11.121.2
                [2019/11/13 19:45:59.773] Latest deploy version:
                [2019/11/13 19:45:59.773] 11.121.2

                Comment


                • #9
                  I finally found at least a work-around to this issue by using a custom Java Home parameter with a value of "c:\Program Files\Java\bin\" I just added it using the fancy new MirthAdministrator Launcher 1.1.10.
                  You can see it in the screenshot atache'-monte'.




                  It has to be something with the JRE and JVM. I tried re-installing, un-installing, standing on my head for Java all to no avail.

                  Things that make you drink.

                  Cheers!
                  Mike
                  Attached Files

                  Comment


                  • #10
                    Originally posted by maharney View Post
                    I finally found at least a work-around to this issue by using a custom Java Home parameter with a value of "c:\Program Files\Java\bin\" I just added it using the fancy new MirthAdministrator Launcher 1.1.10.
                    You can see it in the screenshot atache'-monte'.
                    You should be able to just put "https://localhost:8433" as your address in the admin launcher. You don't need to point it to webstart.

                    Comment

                    Working...
                    X