Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

File Reader and SMB connection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • File Reader and SMB connection

    I have mirth on server1 within domain1. An SMB connection has been created to allow server1 to connect with server2 which is outside of domain1. I can easily access directories on server2 using windows explorer from server1. But I am unable to connect from Mirth using a filereader. I recieve the following error:


    [2008-07-30 14:37:34,858] ERROR (org.mule.impl.model.seda.SedaModel:374): Error starting component [587fc231-616d-447e-89dc-e0ecfddde392]
    org.mule.providers.FatalConnectException: ReconnectStrategy "org.mule.providers.SingleAttemptConnectionStrateg y" failed to reconnect receiver on endpoint "file:////server2/MirthFileTransfer/PerformanceIndicators/"


    Any help would be great

  • #2
    Re:File Reader and SMB connection

    Mirth 1.7.1 does not support connecting to Samba shares with authentication. The updated File Connector with support for connecting to Samba and Windows shares with authentication is in the repository (as of this morning) and will be available in the 1.8 release.
    Gerald Bortis | Chief Information Officer | Mirth Corporation

    Comment


    • #3
      Re:File Reader and SMB connection

      So, when will 1.8 come out? I'm trying to connect to a samba share with a filereader and have had no luck. I run the 1.7.1 Mirth Service under a user that has access. I even set up a mapped drive on that user's windows account.

      I still get that same error that mwoods has when I try T:\ (which I mapped to a network path). Mirth rewrites that as T:/ , but I still can't seem to get to the samba share. Is there any work around available now?

      Post edited by: jmoran, at: 10/02/2008 15:19

      I FOUND A WORKAROUND! Using the actual network path "//server1/folder1/" worked (folder1 allows full access)

      Post edited by: jmoran, at: 10/02/2008 15:24

      Comment


      • #4
        Re:File Reader and SMB connection

        Chatter in IRC from the team at WebReach indicates that the 1.8 RC should be out today.
        Jon Bartels

        Zen is hiring!!!!
        http://consultzen.com/careers/
        Talented healthcare IT professionals wanted. Engineers to sales to management.
        Good benefits, great working environment, genuinely interesting work.

        Comment

        Working...
        X