Announcement

Collapse
No announcement yet.

Port 8080 and 8443 not running

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port 8080 and 8443 not running

    we have been using Mirth Connect for email for months and suddenly we can't access the admin GUI. After checking, the port 8080 and 8443 not running.

    The channels port (eg 8101, 8102, ... 8109) are running where we can email through the API. But we cant modify existing channel (since cannot login into admin UI)

    I've do these:
    service mcservice stop
    service mcservice start
    Including:
    systemctl reboot
    Any idea what can be the cause? I'm considering to reinstall with newer version 3.8 (current version 3.5.1)

    This is the top of /opt/mirthconnect/conf/mirth.properties
    # Mirth Connect configuration file

    # directories
    dir.appdata = appdata
    dir.tempdata = ${dir.appdata}/temp

    # ports
    http.port = 8080
    https.port = 8443

  • #2
    What does netstat output on the machine running Connect? Are the ports actually not listening, or is the problem more that you aren't able to connect via those ports on your local workstation?
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      After asking advice from my infra team, they said its due to firewall. Nothing to do with my apps (Mirth).

      Thank you for your reply and sorry for the misunderstanding (I'm asking all 360 possibilities since I've stuck for weeks)

      Comment

      Working...
      X