Announcement

Collapse
No announcement yet.

Parsing excel using POI 4.0.0 gives xmlbeans library conflict

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Parsing excel using POI 4.0.0 gives xmlbeans library conflict

    Hi,

    When trying to parse a XLSX file using POI 4.0.0 I get a NoSuchMethodError on
    org.apache.xmlbeans.XmlOptions.setEntityExpansionL imit(I)

    I'm including xmlbeans-3.0.1.jar in the custom-lib folder, which is the version of xmlbeans that's included in the .bin package of POI 4.0.0.

    So, it looks like there is already a version of xmlbeans on the classpath.
    I would like to find out which version of xmlbeans is used, so I can use the appropriate version of POI that is compatible with that version.

    I'm using Mirth Connect 3.6.2.

    Is there a way to find the conflicting library?

    How do you typically deal with these kind of issues?

    Thank you,
    Kristof Taveirne

  • #2
    Did you ever resolve this?

    I have a similar issue with an xmlbeans conflict and I can't figure out how to make sure it is using the right one, or even which one it is using.

    Comment


    • #3
      This is what the isolatedClassLoader is for. See this post: https://forums.mirthproject.io/node/18965

      Comment

      Working...
      X