Announcement

Collapse
No announcement yet.

Connect 3.7 requires internet connection to launch administrator

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Connect 3.7 requires internet connection to launch administrator

    I have just upgraded from Mirth Connect 3.5 running under JRE 8.
    We now use OpenJDK 11 and as NextGen Connect 3.7 supports Open JDK 11 we decided to go with this version.
    However Java WebStart is no longer supported and instead there is a Web launcher using JNLP.

    Problem is Web administrator launcher requires an internet connection to start.
    However NextGen Connect 3.7 is running in a client production environment behind a firewall and we have no internet access.

    Is there a solution for this or a workaround. The client will not allow access to the internet, so we are stymied somewhat. Connect 3.7 is installed okay, butt we cannot open Mirth Administrator.

    Many thanks in advance
    Robin

  • #2
    It doesn't actually require the internet, you can skip that prompt. The reason you see that is because the Administrator Launcher attempts to check for updates on start.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      Many Thanks for your prompt reply. I installed the separate Administrator Web launcher and it then allowed me to start Mirth Connect administrator.

      Regards
      Robin

      Comment


      • #4
        I'm in the same situation. I installed the Launcher and at first I thought it wasn't working. After I canceled out of the dialog asking about an internet connection, it was stuck on verifying the cache. Eventually the login dialog appeared.

        I timed it. It spent 3:48 on "verifying the cache". Is there any way to bypass this?

        Comment


        • #5
          I've got the same annoying issue. Always on servers without an Internet Connection.
          Tried already disabling these settings in the embedded Java from the MC Administrator Launcher (see attached)
          But the issue persists ...
          Attached Files
          Mirth Connect Server 3.4.1.8057
          Java version: 1.8.0_101

          on Debian 8.5 and various Winboxes

          Comment

          Working...
          X