Announcement

Collapse
No announcement yet.

JMS trouble

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JMS trouble

    Hi all!
    Use Mirth version 1.7.0.3285 and JBoss 4.2.2 with JMS queue configured.
    I am trying to connect to JMS queue.

    My JMS writer configurations are:

    Provider URL: jnp://localhost:1099
    Initial Context Factory: org.jnp.interfaces.NamingContextFactory
    Connection Factory: java:/ConnectionFactory


    But I get the following error

    com.webreach.mirth.connectors.jms.JmsConnector: Unable to create Jms connection
    java.lang.IllegalArgumentException: connectionFactory cannot be null
    at com.webreach.mirth.connectors.jms.Jms11Support.cre ateConnection(Jms11Support.java:66)
    at com.webreach.mirth.connectors.jms.JmsConnector.cre ateConnection(JmsConnector.java:208)
    at com.webreach.mirth.connectors.jms.JmsConnector.doC onnect(JmsConnector.java:219)
    at org.mule.providers.AbstractConnector.connect(Abstr actConnector.java:795)
    at org.mule.providers.SingleAttemptConnectionStrategy .doConnect(SingleAttemptConnectionStrategy.java:32 )
    at org.mule.providers.AbstractConnectionStrategy.conn ect(AbstractConnectionStrategy.java:67)
    at org.mule.providers.AbstractConnector.connect(Abstr actConnector.java:789)
    at org.mule.providers.SingleAttemptConnectionStrategy .doConnect(SingleAttemptConnectionStrategy.java:32 )
    at org.mule.providers.AbstractConnectionStrategy.conn ect(AbstractConnectionStrategy.java:67)
    at org.mule.providers.AbstractConnector.startConnecto r(AbstractConnector.java:251)
    at org.mule.MuleManager.startConnectors(MuleManager.j ava:767)
    at org.mule.MuleManager.start(MuleManager.java:728)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:207)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:194)
    at com.webreach.mirth.server.Mirth.startMule(Mirth.ja va:231)
    at com.webreach.mirth.server.Mirth.startup(Mirth.java :160)
    at com.webreach.mirth.server.Mirth.run(Mirth.java:110 )

    Help, please .

    Thanks in advance,
    oleg.
Working...
X