Announcement

Collapse
No announcement yet.

Problems connecting to dockerized Mirth in localhost

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems connecting to dockerized Mirth in localhost

    Hello all,

    I have a dockerized Mirth instance in my local machine that is up and running (I can connect using the jnlp and web interfaces by https://localhost:8443) but when I try to connet to a TCP listener that I have just created I am getting the "Connection refused: connect" error.

    I am trying to run the TCP Listener in 6661 port (I have already changed it a couple of times 8881, 8882, etc.) but still not working. I have checked connections status in my machine (Windows) with netstat -an and I can not see my listener in port 6661...I have also created a rule in the Windows firewall to alow connections in the different ports. I can get the same error if I just change the port so it seems that Mirth is not correctly publishing the listener...

    Any idea of what could be the problem?

    Thanks in advance,
    Angel

  • #2
    Hi all,

    I have already solved the problem! I needed to map ports on dockerized Mirth to ports in my OS. As soon as I have included also the mapping for port 8081, it works.

    Thanks,
    Angel

    Comment

    Working...
    X