Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less Invalid encoding for signature (SOLVED)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid encoding for signature (SOLVED)

    Hi everyone,

    Currently we try to upgrade our Mirth Connect from 3.4 to 3.11, with installation of OpenJRE11, but we always got the following exception. I also tried to replace jsch-0.1.54.jar with jsch-0.1.55.jar, but no help. The SFTP channel with a public key file setting works fine, just the error appears sometimes. Did someone experience the issue before? I really appreciate any advice! Thank you so much!

    ERROR 2021-09-01 14:17:45,078 [File Reader Polling Thread on WSLH_ORU_CERNER_SFTP_A (2876bcf1-6735-446a-a249-159d1d2dcb88) < 2876bcf1-6735-446a-a249-159d1d2dcb88_Worker-1] com.mirth.connect.connectors.file.FileReceiver: Error polling in channel: 2876bcf1-6735-446a-a249-159d1d2dcb88
    com.jcraft.jsch.JSchException: Session.connect: Invalid encoding for signature
    at com.jcraft.jsch.Session.connect(
    at com.mirth.connect.connectors.file.filesystems.Sftp Connection.<init>(
    at com.mirth.connect.connectors.file.filesystems.File SystemConnectionFactory.makeObject(FileSystemConne
    at eate(
    at rrowObject(
    at rrowObject(
    at tConnection(
    at com.mirth.connect.connectors.file.FileReceiver.lis tFiles(
    at com.mirth.connect.connectors.file.FileReceiver.pol l(
    at torJob.execute(
    at 13)
    at org.quartz.simpl.SimpleThreadPool$ (

  • #2
    Does somebody know if it is possible to disable the quartz? Thank you!


    • #3
      Your question doesn’t make sense. Your problem seems to be the encoding of an sftp key.
      Diridium Technologies, Inc.


      • #4
        Originally posted by pacmano View Post
        Your question doesn’t make sense. Your problem seems to be the encoding of an sftp key.
        Thank you Pacmano! But the encoding of my sftp key is a standard public key, and it works fine on Mirth 3.4.1 and JRE7. The strange thing is that testing read/write on the sftp URL was successful despite the exception on Mirth 3.11 and OpenJDR11.


        • #5
          Did you restart the service after applying jsch-0.1.55?


          • #6
            Originally posted by upstart33 View Post
            Did you restart the service after applying jsch-0.1.55?
            Great! Thank you soooo much! It looks jsch-0.1.55 resolves the error! I previously also tested jsch-0.1.55.jar, but I didn't completely delete jsch-0.1.54.jar, and I just renamed it as jsch-0.1.54.jar_ and left it in the server-lib. I really appreciate it! upstart33