Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Administrator Launcher very slow to load

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Administrator Launcher very slow to load

    I've converted to the Administrator Launcher as I manage several mirth environments.
    The issue I have is it's extremely slow in loading the Mirth Administrator for all connections. It seems to sit on Verifying from cache:... and the value here is often different.
    Any way to speed this up? When I say slow, its much slower than when I used the Web page and web launch. It can take almost 5 minutes to load the administrator.

  • #2
    Bumping for Same

    Migrating to new servers and using 3.8.1 and newest launcher. I'm seeing the same, roughly 5 minutes to start up, seeming stuck on Verifying from cache. Currently, stuck on libs/tcp/tcp-client.jar. It always comes up eventually, but crazily longer amount of time.

    It's not the launcher, though. We used the launcher before in other server environments and it starts up within seconds.

    Comment


    • #3
      I am using 3.8 and the launcher takes about 15 seconds to get to the MC login screeen.

      I tested on 3.8.1 and have the same results.

      Have you tried increasing the Max Heap Sizw?
      Best,

      Kirby

      Mirth Certified|Epic Bridges Certified|Cloverleaf Level 2 Certified

      Appliance Version 3.11.4
      Mirth Connect Version 3.8.0
      Java Version 1.6.0_45-b06
      Java (64 bit) Version 1.6.0_45-b06
      Java 7 (64 bit) Version 1.7.0_151-b15
      Java 8 (64 bit) Version 1.8.0_181-b13
      PostgreSQL Version 9.6.8

      Comment


      • #4
        I'm also facing the same issue.

        My mirth is taking ages to open the administrative from the launcher, more then 20m and it keeps stucking at "verifying from cache: ..."

        My mirth version is 3.8.1

        Comment


        • #5
          Not Heap Size

          Heap size doesn't seem likely. It's 512Mb, which is the same we have on other servers that aren't having this issue.

          This instance does have many Gold Level extensions installed, whereas my others don't. Is it maybe related to that... high loading/verifying cost on those? I dunno, but it will be a problem one day when there is chaos and I can't get in for 5+ minutes to assess.

          Comment


          • #6
            Have you checked your antivirus?

            I use Kaspersky. It scans every jar file and makes the whole process really slow and CPU consuming.

            Comment


            • #7
              I got McAfee Endpoint Security, I tried to disable all scanning and properties I could to check if it had impact.
              But the slow Launcher continues to freeze and take ages at "Verifying from cache: ... " steps

              Comment


              • #8
                Administrator Launcher Slow to Load after upgrade

                This is happening to me after upgrading from 3.8 to 3.9. The launcher takes several minutes verifying cache.

                Comment


                • #9
                  I'm having the same problem. the launcher can't talk to the internet, because the machine is behind the proxy.
                  I had it solved by adding -Djava.net.useSystemProxies=true to the launcher.vmoptions file.
                  It worked for a few days, but today it came back again. So annoying, why can't we have an option to ignore the cache verifying?

                  Comment


                  • #10
                    I have the same issue running the Mirth Launcher from a bastion host. It takes anywhere from 3-5 minutes (sometimes way longer) while it is verifying items from the cache. I've cleared the java cache, but, that hasn't done any good. I'm running Mirth 3.8.0 on all of my servers (gke based) With the 1.1.0 Launcher (windows server running < 5% CPU, 8 cores, 30% ram (64GB avail)). We routinely have 3-4 users on the box but resources aren't an issue.

                    The weird thing is we didn't have this problem with the launcher, going to the same servers, on previous builds of our bastion host. So, we must have configured something differently. I just don't know what.

                    I've even excluded both the Mirth and Mirth Launcher directories from Windows AV but that hasn't helped.
                    Where is narupley when you need him?
                    Last edited by greenhead916; 03-09-2021, 04:46 AM.

                    Comment


                    • #11
                      It might be caused by the validation of the code signing certificate that has to run into a timeout because the internet is not accessible by java.

                      Deactivating the certificate checks for signed code should drastically reduce loading times:

                      JavaControlPanel.png

                      But be aware of the potential security implications that might come w/ deactivated certificate checking.

                      Comment


                      • #12
                        I'm pretty sure that the java control panel and the java cache don't apply to the Launcher, because it doesn't use javaws.

                        Comment


                        • #13
                          I tested odo 's suggestion and it unfortunately did not help. The issue is between the time I select the connection and I get the login screen. I hang on "Verifying from cache: ...." It isn't always the same thing after this. Right now its libs/pdfviewer/lib/PDFRenderer.jar but sometimes (most of the times) it is something else that is getting pulled from the cache.

                          Comment


                          • #14
                            https://forums.mirthproject.io/forum...812#post179812

                            Comment

                            Working...
                            X