Announcement

Collapse
No announcement yet.

Mirth Administrator Issue after Upgrade from 3.4.0 to 3.6.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mirth Administrator Issue after Upgrade from 3.4.0 to 3.6.1

    Initial Setup:
    Mirth Connect 3.4.0
    MS SQL Database
    Java 8

    Performed an in-place upgrade to 3.6.1... Mirth Connect Service started properly, with no errors in the Mirth Server log. When logging into the Mirth Administrator, I received an error message "There was an error connecting to the server at the specified address. Please verify that the server is up and running". The server is up, channels deployed and processing message (('m able to view the channels and counters in the Web Dashboard). I noticed the error seems to occur when the Administrator is Loading Extensions. In addition, the Java console logged the following error:

    java.lang.NullPointerException
    at com.mirth.connect.client.ui.components.tag.MirthTa gField.<init>(MirthTagField.java:74)
    at com.mirth.connect.client.ui.ChannelPanel.initCompo nents(ChannelPanel.java:3344)
    at com.mirth.connect.client.ui.ChannelPanel.<init>(Ch annelPanel.java:202)
    at com.mirth.connect.client.ui.Frame.setupFrame(Frame .java:401)
    at com.mirth.connect.client.ui.Mirth.<init>(Mirth.jav a:63)
    at com.mirth.connect.client.ui.LoginPanel$8.handleSuc cess(LoginPanel.java:524)
    at com.mirth.connect.client.ui.LoginPanel$8.doInBackg round(LoginPanel.java:443)
    at com.mirth.connect.client.ui.LoginPanel$8.doInBackg round(LoginPanel.java:414)
    at javax.swing.SwingWorker$1.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at javax.swing.SwingWorker.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  • #2
    Are you using the new Administrator Launcher? If not, have you cleared your Java cache?
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      I've tried both the Administrator Launcher and the 3.6.1 Mirth Connect Administrator. I've cleared the Java cache, but still receive the same error.

      Comment


      • #4
        Restored DB and re-installed 3.4.0.8000... Mirth Connect is back up and running.

        I noticed one error in the Server Log after I tried to upgrade and logging stopped after this error. Not sure if it's related...

        ERROR 2018-11-16 12:29:31,125 [Main Server Thread] com.mirth.connect.server.controllers.DefaultExtens ionController: Error instantiating plugin: Server Log
        java.lang.NullPointerException
        at com.mirth.connect.plugins.serverlog.ServerLogProvi der.newServerLogReceived(ServerLogProvider.java:57 )
        at com.mirth.connect.plugins.serverlog.ArrayAppender. append(ArrayAppender.java:51)
        at org.apache.log4j.AppenderSkeleton.doAppend(Appende rSkeleton.java:251)
        at org.apache.log4j.helpers.AppenderAttachableImpl.ap pendLoopOnAppenders(AppenderAttachableImpl.java:66 )
        at org.apache.log4j.Category.callAppenders(Category.j ava:206)
        at org.apache.log4j.Category.forcedLog(Category.java: 391)
        at org.apache.log4j.Category.debug(Category.java:260)
        at com.mirth.connect.server.ExtensionLoader.getContro llerInstance(ExtensionLoader.java:134)
        at com.mirth.connect.plugins.serverlog.ServerLogContr oller.getInstance(ServerLogController.java:23)
        at com.mirth.connect.plugins.serverlog.ServerLogProvi der.initialize(ServerLogProvider.java:49)
        at com.mirth.connect.plugins.serverlog.ServerLogProvi der.init(ServerLogProvider.java:53)
        at com.mirth.connect.server.controllers.DefaultExtens ionController.initPlugins(DefaultExtensionControll er.java:272)
        at com.mirth.connect.server.Mirth.startup(Mirth.java: 241)
        at com.mirth.connect.server.Mirth.run(Mirth.java:153)
        ERROR 2018-11-16 12:29:31,125 [Main Server Thread] Server: Exception in thread "Main Server Thread" java.lang.NullPointerException


        I guess I'll need to come up with another plan to upgrade without a losing stored message data.
        Last edited by shaftkb; 11-16-2018, 12:12 PM.

        Comment

        Working...
        X