No announcement yet.

SFTP Private/Public key pair issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP Private/Public key pair issue

    I have a private and public key pair which I am supposed to use to establish an SFTP connection.
    I have entered the path to the Private Key under the SFTP settings where it says “Public/Private Key File:” By doing this I am able to successfully test connection to the SFTP. But I receive an error message when I attempt to send any messages to the SFTP, the error is: “ERROR: Error writing file [SftpException: File not found]”
    I am not sure where should the public key should be entered? I’ve tried the following:
    1. Enter public key path at “Public/Private Key File:” where the private key path is currently entered however I receive an error message that states, “Invalid Private Key.”
    2. Enter public key path under “Known Host File:” and Private Key path under “Public/Private Key File:”, this connects to the SFTP but I am not able to send any files over. With this settings a I am receiving the same error message “ERROR: Error writing file [SftpException: File not found]”
    Just to make sure that there was no issues with the message itself, I added a second SFTP destination that does not require any Private/Public keys, and the message always makes it across to the second SFTP, but the first SFTP destination keeps erroring.

    Any help on this would be greatly appreciated.

  • #2
    I had the same problem and found I needed to use the full path and file name. So something like /home/username/.ssh/publickey.txt