Announcement

Collapse

Mirth Connect 3.12.0 Released!

Mirth Connect 3.12.0 is now available as an appliance update and on our GitHub page. This release includes database performance improvements, improves visual HL7 representation, message pruning, keystore handling, PDF generation, community contributions, and fixes several security vulnerabilities. This release also contains many improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

JAXB 2.0/2.1 conflict

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JAXB 2.0/2.1 conflict

    I've written a transformer that calls out to a Java class that uses JAXB to convert a HAPI-parsed HL7 message into XML. A JUnit test for the class works fine using both the 2.0 and 2.1 releases but when I run the class in the context of Mirth I get:

    Exception java.lang.LinkageError:
    JAXB 2.0 API is being loaded from the bootstrap classloader, but this RI (from jar:file:/D:/mirth/mirth-1.7.0/./lib/jaxb-impl.jar!/com/sun/xml/bind/v2/model/impl/ModelBuilder.class) needs 2.1 API. Use the endorsed directory mechanism to place jaxb-api.jar in the bootstrap classloader. (See http://java.sun.com/j2se/1.5.0/docs/guide/standards/)

    I then built my Java class(es - the transformer class plus the JAXB classes it operates on) (that I deploy as a JAR in the custom directory) against jaxb-api.jar, jaxb-impl.jar, jaxb-xjc.jar and jsr173-1-0-api.jar from mirth/lib and activation*.jar from mule. Again it works fine standalone but gives the same error in Mirth.

    The code falls over when it tries to create a JAXBContext.

    Any suggestions?
Working...
X