Announcement

Collapse
No announcement yet.

SSH host Key

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SSH host Key

    Using an file writer with the sftp method , can I add a RSA2 SSH host key setting ? I am not seeing any option for that setting or do I add it to the registry?

  • #2
    What version are you using? In 3.3 we added advanced options to the SFTP settings. Among them is the ability to turn host key checking on or off, and to use a specific known hosts file.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      Hi Narupley, I am using 3.3.1.7856, I tested the turn host key on or off but how do I use the hosts file?

      Comment


      • #4
        You don't have to; it's optional. By default JSch (the library used for SFTP) will add host keys to the standard known hosts file, which differs depends on what OS you're using. On Linux and OSX for example it would be in ~/.ssh/known_hosts.
        Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

        Nicholas Rupley
        Work: 949-237-6069
        Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


        - How do I foo?
        - You just bar.

        Comment


        • #5
          When I connect using FileZilla it adds the SshHostKey to the Putty folder in the regustry. In the Mirth Method setting I have Auth passwork Host Key checking set to ask but I am still getting auth fail.

          Comment


          • #6
            Any help with this problem would be great.

            Comment


            • #7
              sftp method getting auth fail.

              Hi,
              I am using Mirth Connect 3.3.1.7856, and created file writer with the Method sftp.

              In the SFTP address field, I entered the IP followed by a colon and portnumber
              I entered the User Name/Password.

              When I select "Test Write" I get an "Auth fail" warning.

              Am I missing something? I try a lot of different combination in the sftp setting but I always get that warning.

              If I use the FileZilla application I have no problems connecting. I do an a prompt to add the sshhostkey file.

              Any advice on how to get Mirth to connect?

              Thanks

              Comment


              • #8
                sftp auth fail

                Hi,
                I am using Mirth Connect 3.3.1.7856, and created file writer with the Method sftp.

                In the SFTP address field, I entered the IP followed by a colon and portnumber
                I entered the User Name/Password.

                When I select "Test Write" I get an "Auth fail" warning.

                Am I missing something? I try a lot of different combination in the sftp setting but I always get that warning.

                If I use the FileZilla application I have no problems connecting. I do an a prompt to add the sshhostkey file.

                Any advice on how to get Mirth to connect?

                Thanks

                Comment


                • #9
                  I am having this same issue. I can connect to the SFTP site with FileZilla or WINSCP once I accept the unknown host key. I do not know how to add the host key to Mirth. I have opened the sftp method settings but unsure where or how I add the host key. Are there any instructions on how to do this or has anyone been able to successfully add one?

                  Thanks,
                  Paul

                  Comment

                  Working...
                  X