Announcement

Collapse
No announcement yet.

Timeout waiting for response: Read timed out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Timeout waiting for response: Read timed out

    I have a HL7 v2 to v3 transformation channel with a source (batch) file reader and a TCP (MLLP) Sender destination. The client side is a GE IDX interface that listens on this remote TCP IP/Port and sends an ACK back. They are telling me that they are able to receive my message just fine but I'm unable to see an ACK. I've disabled all the firewalls on my server and tried setting the MLLP Sender response timeout as high as 30 mins with no luck. I've attached the error and my destination settings.
    Attached Files
    Last edited by vkrishna; 01-19-2016, 06:12 AM.

  • #2
    Are you sure receiving system is sending back an ACK? Also, if you have Validate response set to no, the Ack is ignored and the status of the message is marked as sent. Try changing that to yes.

    Comment


    • #3
      Have GE send you an example of the ACK's they are sending.
      Best,

      Kirby

      Mirth Certified|Epic Bridges Certified|Cloverleaf Level 2 Certified

      Appliance Version 3.11.4
      Mirth Connect Version 3.8.0
      Java Version 1.6.0_45-b06
      Java (64 bit) Version 1.6.0_45-b06
      Java 7 (64 bit) Version 1.7.0_151-b15
      Java 8 (64 bit) Version 1.8.0_181-b13
      PostgreSQL Version 9.6.8

      Comment


      • #4
        I had validate response set to Y first, still the same result. Flipped it back to Y.
        Last edited by vkrishna; 01-18-2016, 05:00 PM.

        Comment


        • #5
          Format of the msg I sent:

          MSH|^~\&|CERNER|USC|GEHC_VM_REG|USC|201507010002|| ADT^A04|Qxxx491674T201945230X697313|P^T|2.4||
          EVN|A04|201507010002|||SYS
          PID|0001||xxxxxxxxx^MRN
          ....

          Response that they're sending back:
          MSH|^~\&|||||201601180110||ACK^P01|Qxxx491674T2019 45230X697313|P|2.3|||||ASCII|
          MSA|AA|Qxxx491674T201945230X697313|||||
          Last edited by vkrishna; 01-18-2016, 09:49 PM.

          Comment


          • #6
            It appears there is a difference in the message control ID.
            MSH - Qxxx491674T2019 45230X697313
            MSA - Qxxx491674T201945230X697313


            Notice the space in the middle.

            Under Set Data Types --> Response --> Inbound Properties, uncheck "Validate Message Control ID"
            Best,

            Kirby

            Mirth Certified|Epic Bridges Certified|Cloverleaf Level 2 Certified

            Appliance Version 3.11.4
            Mirth Connect Version 3.8.0
            Java Version 1.6.0_45-b06
            Java (64 bit) Version 1.6.0_45-b06
            Java 7 (64 bit) Version 1.7.0_151-b15
            Java 8 (64 bit) Version 1.8.0_181-b13
            PostgreSQL Version 9.6.8

            Comment


            • #7
              That additional space could've been a typo, they sent me the ack through email (posted) since I wasn't able to see them on my end. I do have the validate message control ID unchecked. I attached a screenshot of that and my channel if you could please take a look? I am clueless at the moment.

              Comment


              • #8
                When you click the response tab on the message you send, what do you see?

                Also, have you tried recreating your channel?
                Best,

                Kirby

                Mirth Certified|Epic Bridges Certified|Cloverleaf Level 2 Certified

                Appliance Version 3.11.4
                Mirth Connect Version 3.8.0
                Java Version 1.6.0_45-b06
                Java (64 bit) Version 1.6.0_45-b06
                Java 7 (64 bit) Version 1.7.0_151-b15
                Java 8 (64 bit) Version 1.8.0_181-b13
                PostgreSQL Version 9.6.8

                Comment


                • #9
                  Go to your channel, click on the "Summary tab", click the button "Set Data Types", click on the destination you are sending to. Under the inbound and outbound properties, scroll down and look at the Response generation. I would confirm with the vendor that these settings are what you are expecting.

                  Additionally, Click on the "destinations tab" go to "Edit response" under channel tasks. I would confirm that you didn't accidentally place a message template here or alter the response in any way.

                  Comment


                  • #10
                    It was an issue on the GE side. They updated the control characters towards the end of the ACK and I started seeing the responses on my end. Thanks for all the help.

                    Comment


                    • #11
                      Originally posted by kirbykn2 View Post
                      It appears there is a difference in the message control ID.
                      MSH - Qxxx491674T2019 45230X697313
                      MSA - Qxxx491674T201945230X697313


                      Notice the space in the middle.

                      Under Set Data Types --> Response --> Inbound Properties, uncheck "Validate Message Control ID"
                      MSH.12 of his message should match with MSA.2 in the response, which is true in his case. There is no difference in the message control ID.

                      Comment

                      Working...
                      X