Announcement

Collapse
No announcement yet.

Stop sending FIN ACK to the message sender.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stop sending FIN ACK to the message sender.

    Mirth Connect version: 3.2.2
    Channel Type: TCP listener with Keep Connection Open - yes setting.

    I'm using a TCP listener channel running on one of the open ports.

    While the sender is sending a HL7 message to my channel. It establishes the connection, receive the message and then responding back to the sender with FIN <ACK> which basically means connection terminate request from my understanding.

    I want to keep the connection open and the FIN ACK should not be sent to the sender. Please help me to find a solution for this problem.

    Note: I have used wireshark to monitor the FIN ACK signal.

    Thanks in advance!

  • #2
    What are your TCP Listener settings? If you have Keep Connection Open enabled, then the connection will not be closed on the server side unless a network-related error occurs.

    Note that FIN/ACK means that the server is responding to a FIN packet. That means the client is the one closing the connection, not the server.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      Hi Narupley,

      Thank you for the response. Is there any chance that we stop sending FIN/ACK eventhough client sends a FIN packet?

      Thank you,
      Jey

      Comment


      • #4
        Originally posted by jeyasithar View Post
        Hi Narupley,

        Thank you for the response. Is there any chance that we stop sending FIN/ACK eventhough client sends a FIN packet?

        Thank you,
        Jey
        I don't understand the question.
        Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

        Nicholas Rupley
        Work: 949-237-6069
        Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


        - How do I foo?
        - You just bar.

        Comment


        • #5
          The sender is requesting us not to send FIN/ACK. I was trying to figure out a way to stop sending this packet.

          Thanks for clarifying that client used to send FIN/ACK. I have verified the channel and found that the response destination had the issue. I didn't realize that sender was talking about our destination.

          This thread can be closed as fixed.

          Comment


          • #6
            TCP Sender in Mirth destination is sending FIN/ACK

            OK. I'm having TCP sender in Mirth destination. I have the destination settings as keep connection open. Even-though Mirth TCP sends FIN packet and also terminate the connection.

            Can you please help me on this? I want to keep the connection open.

            Attachments:
            Destination settings - Keep Connection Open - Yes
            Connection log - Connection disconnected
            Channel - Actual channel
            Network log - Wireshark log
            Attached Files

            Comment


            • #7
              If you want to keep the connection open indefinitely, then set the send timeout to 0.
              Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

              Nicholas Rupley
              Work: 949-237-6069
              Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


              - How do I foo?
              - You just bar.

              Comment


              • #8
                Originally posted by narupley View Post
                If you want to keep the connection open indefinitely, then set the send timeout to 0.
                Thank you very much! it works!

                Comment

                Working...
                X