Announcement

Collapse
No announcement yet.

ER7Serializer error ERROR MESSAGE: Error converting ER7 to XML

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ER7Serializer error ERROR MESSAGE: Error converting ER7 to XML

    Hi there,
    Mirth (3.1.1) has started throwing the below error:-
    ER7Serializer error
    ERROR MESSAGE: Error converting ER7 to XML
    org.xml.sax.SAXException: Unable to parse message. It is NULL or too short.
    at com.mirth.connect.plugins.datatypes.hl7v2.ER7Reade r.parse(ER7Reader.java:63)
    at com.mirth.connect.plugins.datatypes.hl7v2.ER7Seria lizer.toXML(ER7Serializer.java:213)
    at com.mirth.connect.donkey.server.channel.FilterTran sformerExecutor.processConnectorMessage(FilterTran sformerExecutor.java:91)
    at com.mirth.connect.donkey.server.channel.Channel.pr ocess(Channel.java:1473)
    at com.mirth.connect.donkey.server.channel.Channel.pr ocessSourceQueue(Channel.java:1738)
    at com.mirth.connect.donkey.server.channel.Channel.ru n(Channel.java:1725)
    at java.lang.Thread.run(Unknown Source)

    The error started coming after upgrading Java 7 to Java 8. Sender confirmed that the message is not blank but we don't see the messages in the source to validate.

    Is it a Java 8 issue or related to data content?
    Last edited by haym; 10-28-2015, 10:27 AM.

  • #2
    I was able to fix this problem on my channel by changing the File Size (bytes): to 1 on the Source panel. Maybe this will help you.

    Comment


    • #3
      Thanks Dac1005. Are you using Java 8 as well?

      Comment


      • #4
        It is a Web Service listener and it has no file size property to edit. Anything I should try?

        Comment


        • #5
          I'm facing the same problem with java 7, so I think it is no java related.

          Which version of mirth are you using?

          Regards

          Comment


          • #6
            Hi Ferdinand,
            I am using 3.1.1 version. Please let me know if you find a solution.

            Comment


            • #7
              Same problem here. I'm using Mirth 3.2.2 and Java 1.7.0_79.
              The source message is HL7 and has a filesize of 0. But when I take a look at the file in the error directory, it has a size of 1.50 KB.
              I have even tried to enable "check file age" and set it to 1000ms, but that doesn't fix the problem.
              Last edited by fluancefg; 12-03-2015, 02:27 AM.

              Comment


              • #8
                If you're using a File Reader, you can set the minimum File Size to 1, so that 0 byte files will not be picked up.

                If you're using a Web Service Listener, then it's really an issue with the client sending you data. Go to the originating system and tell them to stop sending you empty (or malformed) SOAP envelopes.
                Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

                Nicholas Rupley
                Work: 949-237-6069
                Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


                - How do I foo?
                - You just bar.

                Comment

                Working...
                X