Announcement

Collapse
No announcement yet.

is it possible to develop in 3.2.2 and deploy in 3.2.1?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • is it possible to develop in 3.2.2 and deploy in 3.2.1?

    Hi people,
    I'm developing in Mirth for a few different clients (some shared channels, some custom).

    At the moment we have them all on 3.2.1.

    However, I would like to be able to develop in the newest version, then deploy to the clients to whatever version they may be using.
    They would (at the very least be up to the same major version (3), hopefully we can persuade them to upgrade regularly and be on the same minor (3.2) version, but that's not a given (all of them want to controll when the version is updated).
    For me as a developer it's important to be able to test new features, and to be able to advise them on implementing the newer versions.

    However, having two Mirth instances is not all that workable.

    Can someone tell me how I can see what the lowest version is that is compatible with wich version?
    That is:
    current version: 3.2.2 downward compatible down to X.X.X
    version: 3.2.1 downwards compatible down to Y.Y.Y

    I have been searching, but haven't found it yet.
    Any help will be appreciated.

    Jurjan

  • #2
    Channels from older versions can definitely be imported and used in newer versions. However, channels from newer versions can not be imported into older versions.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      I was afraid of that.

      But how can I then test new features, check if old channels continue to work as expected?

      This way the developer (who should be the first to test new versions) will be the last (I can only suppoprt customers that have versions higher then mine).

      The only way would be to install a new instance (with it's own challenges) on my computer and hope I don't get confused with the sources.

      Is there a spot where I can drop my request for downwards compatability inside major (or at the very least minor) versions?

      Thanks,
      Jurjan
      Last edited by Jurjan; 08-17-2015, 10:29 PM. Reason: typo

      Comment


      • #4
        Certainly, any feature requests can be made on our public JIRA: http://www.mirthcorp.com/community/i...Dashboard.jspa
        Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

        Nicholas Rupley
        Work: 949-237-6069
        Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


        - How do I foo?
        - You just bar.

        Comment

        Working...
        X