Announcement

Collapse
No announcement yet.

xsi:type functionality

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • xsi:type functionality

    Hey, I tried to parse a CCDA sample document in mirth and found interesting thing. I can read CCDA file in mirth, and I tried to convert the snap of message into JSON format. When I give the CCDA message it throws error saying


    TypeError: The prefix "xsi" for attribute "xsi:type" associated with an element type "value" is not bound.


    When I removed all xsi:type attributes my message is parsed and im getting the JSON output can anyone explain what is happening? and the function of xsi:type in CCDA file? most importantly is my ccda file is fullfilled without xsi:type function?

    Mirth Interface Engineer
    AWS DevOps

  • #2
    You need to turn off Strip Namespaces in that case.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      Could You say me how to do that?.. turning namespaces off? I cannot find in google

      Mirth Interface Engineer
      AWS DevOps

      Comment


      • #4
        Originally posted by vibinChander View Post
        Could You say me how to do that?.. turning namespaces off? I cannot find in google
        Go to the Summary tab in your channel, and click Set Data Types. Make sure to expand all nodes in the tree, and for each inbound/outbound XML property set, uncheck "Strip Namespaces".
        Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

        Nicholas Rupley
        Work: 949-237-6069
        Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


        - How do I foo?
        - You just bar.

        Comment


        • #5
          Originally posted by narupley View Post
          You need to turn off Strip Namespaces in that case.
          Hey there Mr. Rupley, I am running into a similar issue where I am hitting this error roughly 50% of the time, all using CCDs from the same application system. Do you think it is an issue with malformed XML? When I change between namespace stripping enabled and disabled, I still am only getting errors 50% of the time, though I am not entirely certain that it is completely flipped between messages that were working before and stopped.

          Thanks for any input you can provide.

          Comment

          Working...
          X