Announcement

Collapse

Mirth Connect 4.1.0 Released!

Mirth Connect 4.1.0 is now available as an appliance update and on our GitHub page. Mirth Connect 4.1.0 includes new features such as new event log messages, additional fields to the Welcome to Mirth Connect screen, new information included in alerts as well as many smaller changes, updates, and improvements. This release also contains several improvements to commercial extensions. See the release notes for the list of fixes and updates.

Download | See What's New | Upgrade Guide | Release Notes

For discussion on this release, see this thread.
See more
See less

Error in launching channel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in launching channel

    Hii ,

    I am getting a constant error from the mirth ,while i am trying to deploy the channel , for more clarity i am pasting the error below .


    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    "org.mule.config.ConfigurationException: Failed to parse configuration resource "C:\Program Files\Mirth\conf\mule-config.xml" (org.mule.config.ConfigurationException)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:196)
    at com.webreach.mirth.server.Mirth.startMule(Mirth.ja va:178)
    at com.webreach.mirth.server.Mirth.restartMule(Mirth. java:160)
    at com.webreach.mirth.server.Mirth.run(Mirth.java:115 )
    Caused by: org.mule.config.ConfigurationException: Failed to parse configuration resource "C:\Program Files\Mirth\conf\mule-config.xml"
    at org.mule.config.builders.AbstractDigesterConfigura tion.process(AbstractDigesterConfiguration.java:12 1)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:202)
    at org.mule.config.builders.MuleXmlConfigurationBuild er.configure(MuleXmlConfigurationBuilder.java:194)
    ... 3 more
    Caused by: org.mule.umo.lifecycle.InitialisationException: Initialisation Failure: unterminated string literal (e188fbb0-83de-4285-9a9d-2825e04f12f1#7)
    at org.apache.commons.digester.Digester.createSAXExce ption(Digester.java:2919)
    at org.apache.commons.digester.Digester.createSAXExce ption(Digester.java:2945)
    at org.apache.commons.digester.Digester.endElement(Di gester.java:1133)
    at org.apache.xerces.parsers.AbstractSAXParser.endEle ment(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanEndElement(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl$FragmentContentDispatcher.dispatch(Unknown Source)
    at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanDocument(Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
    at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
    at org.apache.xerces.parsers.AbstractSAXParser.parse( Unknown Source)
    at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser .parse(Unknown Source)
    at org.apache.commons.digester.Digester.parse(Digeste r.java:1685)
    at org.mule.config.builders.AbstractDigesterConfigura tion.process(AbstractDigesterConfiguration.java:11 9)
    ... 5 more

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    i had checked the data's which i supply to create the channel ,and it is perfect ,also i had tried to create new channels with different set of data's, again i am getting the same error .Please can anybody help me in tracking this error ?
    if so then it will be a great thing .

    Thank you
    Regards
    Asif

  • #2
    Re:Error in launching channel

    ASIF wrote:
    Caused by: org.mule.umo.lifecycle.InitialisationException: Initialisation Failure: unterminated string literal (e188fbb0-83de-4285-9a9d-2825e04f12f1#7)
    This part of the error makes me think you have a typo or some other syntactical error in your channel definition.

    Mike

    Post edited by: mnowlin, at: 02/05/2008 00:41

    Comment


    • #3
      Re:Error in launching channel

      What version of Mirth are you using? Try validating all of your Javascript (preprocessor, postprocessor and filter/transformers). There is definitely an error with the script. Mirth 1.7 will try to detect these errors sooner, so you might want to try upgrading to it.
      Chris Lang

      Comment


      • #4
        Re:Error in launching channel

        Hii,

        Thank You Very much for the replays .

        That was actually the problem with the sytax error .

        thank you
        regards
        Asif

        Comment

        Working...
        X