Announcement

Collapse
No announcement yet.

Reading PCL printer Stream over TCP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Reading PCL printer Stream over TCP

    Hello,

    I try to get a PCL Stream from a legacy application. It prints Clinical reports using PCl language and is able to send this stream on a network printer (using cups).

    I "receive" the stream but the format seems to not be "understood" by Mirth.
    I 've tried both binary and Text data type. in binary mode, it reads but it's not usable. In text, I get an error like the following :


    [2015-03-06 14:47:00,559] ERROR (com.mirth.connect.connectors.tcp.TcpReceiver:708) : Error receiving message (TCP Listener "Source" on channel a9d7caa6-9109-4c2f-9de8-6f1f8596a500).
    com.mirth.connect.model.transmission.framemode.Fra meStreamHandlerException: End of message bytes (<FS><CR>) not detected. Last bytes received: 5X
    at com.mirth.connect.model.transmission.framemode.Fra meStreamHandler.read(FrameStreamHandler.java:221)
    at com.mirth.connect.connectors.tcp.TcpReceiver$TcpRe ader.readBytes(TcpReceiver.java:773)
    at com.mirth.connect.connectors.tcp.TcpReceiver$TcpRe ader.call(TcpReceiver.java:582 ....


    Could you help me to find the correct combination of settings to read this pure text PCL encoded stream ?

    Thanks in advance.

    Lionel

  • #2
    You need to set your transmission mode to Basic TCP if you're not going to be receiving MLLP. Also, you should be using Binary mode. What do you mean it's "not usable"? It's a Base64 string. You can do whatever you want with it.
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      Great !!! It's working

      thx

      Comment

      Working...
      X