Announcement

Collapse
No announcement yet.

Login Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Login Error

    I'm on version 3.2.0.7628 and I can't remotely connect to the server like usual.
    I've tried the suggested solutions in mirth.properties like
    https.client.protocols = TLSv1
    https.server.protocols = TLSv1.2,TLSv1.1,TLSv1,SSLv2Hello
    or
    https.client.protocols = TLSv1
    https.server.protocols = TLSv1
    and still nothing.
    The error is
    "There was an error connecting to the server at the specified address. Please verify that the server is up and running."
    and my JRE version is 8u31.
    Is there an open issue about this? It seems like I'm not the only one.

  • #2
    Are you sure you have connectivity to that server from your local machine? Can you telnet to the secure HTTPS port?
    Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

    Nicholas Rupley
    Work: 949-237-6069
    Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


    - How do I foo?
    - You just bar.

    Comment


    • #3
      I altered mirth.properties through a remote connection and I can access the 8080 web interface so yeah I can access the server.
      telnet does fail to port 8443, isn't that because either the port is in use or lack of telnet server feature on the server?

      Comment


      • #4
        No that doesn't make sense. You don't need to enable anything on the server side to telnet to a port. The port is also backed by a listening server, so "the port is in use" doesn't make sense either unless the server only allows one connecting socket, which would definitely not be the case here.

        First, check that 8443 is truly up and listening on the server side. Do a netstat on the server itself to verify. If it's up, then it sounds like you have some connectivity problems on your side. You should probably check with your IT department to get those sorted out.
        Step 1: JAVA CACHE...DID YOU CLEAR ...wait, ding dong the witch is dead?

        Nicholas Rupley
        Work: 949-237-6069
        Always include what Mirth Connect version you're working with. Also include (if applicable) the code you're using and full stacktraces for errors (use CODE tags). Posting your entire channel is helpful as well; make sure to scrub any PHI/passwords first.


        - How do I foo?
        - You just bar.

        Comment


        • #5
          Although not yet solved, I think I've found the root of the problem.
          We here changed Mirth's firewall access from public to private.
          Remote connection had a rule to allow it, Mirth doesn't!
          And I guess I wasn't consulted on that!

          Sorry to bother but that sure helped. Thanks Nick!

          Comment

          Working...
          X